POJ 2253:Frogger 求每一条路径最大值里面的最小值

Frogger
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 31490   Accepted: 10150

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

这个题目有些绕,实际上的意思是从点1到点2有很多条路径,每一条抵达的路径都有一个最大值。要求的是这些最大值里面的最小值。

举个例子:点1到点2,有两条路径可以到达,一条是1->3->2,一条是1->4->2。

然后,1->3的值是5,3->2的值是3。那这条路径的最大值是5。之后1->4的距离是4。4->2的距离是3,那这条到达的路径最大值是4。题目要求的意思是求 5和4之间的最小值。
这个就是求最大值里面的最小值的意思。

代码:
#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string>
#include <cstring>
#pragma warning(disable:4996)
using namespace std;

int num;
double stone[205][3];
double dis[205][205];

int main()
{
	int i,j,k,ist=1;
	while(cin>>num)
	{
		if(num==0)
			break;
		cout<<"Scenario #"<<ist<<endl;
		ist++;
		cout<<"Frog Distance = ";

		for(i=1;i<=num;i++)
		{
			cin>>stone[i][1]>>stone[i][2];
		}
		
		for(i=1;i<=num;i++)
		{
			for(j=i+1;j<=num;j++)
			{
				dis[j][i]=dis[i][j]=(double)sqrt((stone[i][1]-stone[j][1])*(stone[i][1]-stone[j][1])+(stone[i][2]-stone[j][2])*(stone[i][2]-stone[j][2]));
			}
		}

		for(k=1;k<=num;k++)
		{
			for(i=1;i<=num;i++)
			{
				for(j=1;j<=num;j++)
				{	
					dis[i][j]=min(dis[i][j],max(dis[i][k],dis[k][j]));
				}
			}
		}

		printf("%.3f",dis[1][2]);
		cout<<endl;
		cout<<endl;
	}
	return 0;
}




版权声明:本文为博主原创文章,未经博主允许不得转载。

原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4928128.html