POJ 1472:Instant Complexity 模拟时间复杂度

Instant Complexity
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 1908   Accepted: 658

Description

Analyzing the run-time complexity of algorithms is an important tool for designing efficient programs that solve a problem. An algorithm that runs in linear time is usually much faster than an algorithm that takes quadratic time for the same task, and thus should be preferred. 

Generally, one determines the run-time of an algorithm in relation to the `size' n of the input, which could be the number of objects to be sorted, the number of points in a given polygon, and so on. Since determining a formula dependent on n for the run-time of an algorithm is no easy task, it would be great if this could be automated. Unfortunately, this is not possible in general, but in this problem we will consider programs of a very simple nature, for which it is possible. Our programs are built according to the following rules (given in BNF), where < number > can be any non-negative integer: 
< Program > ::= "BEGIN" < Statementlist > "END" 

< Statementlist > ::= < Statement > | < Statement > < Statementlist > 

< Statement > ::= < LOOP-Statement > | < OP-Statement > 

< LOOP-Statement > ::= < LOOP-Header > < Statementlist > "END" 

< LOOP-Header > ::= "LOOP" < number > | "LOOP n" 

< OP-Statement > ::= "OP" < number >

The run-time of such a program can be computed as follows: the execution of an OP-statement costs as many time-units as its parameter specifies. The statement list enclosed by a LOOP-statement is executed as many times as the parameter of the statement indicates, i.e., the given constant number of times, if a number is given, and n times, if n is given. The run-time of a statement list is the sum of the times of its constituent parts. The total run-time therefore generally depends on n. 

Input

The input starts with a line containing the number k of programs in the input. Following this are k programs which are constructed according to the grammar given above. Whitespace and newlines can appear anywhere in a program, but not within the keywords BEGIN, END, LOOP and OP or in an integer value. The nesting depth of the LOOP-operators will be at most 10.

Output

For each program in the input, first output the number of the program, as shown in the sample output. Then output the run-time of the program in terms of n; this will be a polynomial of degree Y <= 10. Print the polynomial in the usual way, i.e., collect all terms, and print it in the form "Runtime = a*n^10+b*n^9+ . . . +i*n^2+ j*n+k", where terms with zero coefficients are left out, and factors of 1 are not written. If the runtime is zero, just print "Runtime = 0". 
Output a blank line after each test case.

Sample Input

2
BEGIN
  LOOP n
    OP 4
    LOOP 3
      LOOP n
        OP 1
      END
      OP 2
    END
    OP 1
  END
  OP 17
END

BEGIN
  OP 1997 LOOP n LOOP n OP 1 END END
END

Sample Output

Program #1
Runtime = 3*n^2+11*n+17

Program #2
Runtime = n^2+1997

又是一道很麻烦的模拟。。。输出结果的时候有很多种情况要考虑。

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string>
#include <cstring>
#include <stack>
#pragma warning(disable:4996)
using namespace std;

int oper[15];
int coe[15];
string op, op2;

int change(string x)
{
	int res = 0;
	int i, len = x.length();
	for (i = 0; i < len; i++)
	{
		res = res * 10 + x[i] - '0';
	}
	return res;
}
int main()
{
	//freopen("i.txt", "r", stdin);
	//freopen("o.txt", "w", stdout);

	int i, test, num, flag, another_flag;
	int j, coe_one, n_num;
	cin >> test;

	for (i = 1; i <= test; i++)
	{
		cout << "Program #" << i << endl;
		cin >> op;

		memset(coe, 0, sizeof(coe));
		num = 0;

		while (num != -1)
		{
			cin >> op;
			if (op == "LOOP")
			{
				cin >> op2;
				if (op2 == "n")
				{
					oper[num++] = -1;
				}
				else
				{
					oper[num++] = change(op2);
				}
			}
			else if (op == "END")
			{
				num--;
			}
			else if (op == "OP")
			{
				cin >> op2;
				coe_one = 1;
				n_num = 0;
				for (j = num - 1; j >= 0; j--)
				{
					if (oper[j] == -1)
					{
						n_num++;
					}
					else
					{
						coe_one = coe_one*oper[j];
					}
				}
				coe[n_num] = coe[n_num] + coe_one * change(op2);
			}
		}

		cout << "Runtime = ";

		flag = 0;
		another_flag = 0;
		for (j = 14; j >= 0; j--)
		{
			if (coe[j] == 0)
			{
				continue;
			}
			else
			{
				another_flag = 1;
				if (j == 0)
				{
					if (flag == 0)
					{
						flag = 1;
						cout << coe[j];
					}
					else
					{
						cout << "+" << coe[j];
					}
				}
				else if (j == 1)
				{
					if (flag == 0)
					{
						flag = 1;
						if (coe[j] != 1)
							cout << coe[j] << "*n";
						else
							cout << "n";
					}
					else
					{
						if (coe[j] != 1)
							cout << "+" << coe[j] << "*n";
						else
							cout << "+n";
					}
				}
				else
				{
					if (flag == 0)
					{
						flag = 1;
						if (coe[j] != 1)
							cout << coe[j] << "*n^" << j;
						else
							cout << "n^" << j;
					}
					else
					{
						if (coe[j] != 1)
							cout << "+" << coe[j] << "*n^" << j;
						else
							cout << "+n^" << j;
					}
				}

			}
		}
		if (another_flag == 0)
			cout << 0;
		cout << endl << endl;
	}

	//system("pause");
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4899515.html