POJ1014:Dividing

Dividing
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 63013   Accepted: 16315

Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0". The maximum total number of marbles will be 20000. 
The last line of the input file will be "0 0 0 0 0 0"; do not process this line.

Output

For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.". 
Output a blank line after each test case.

Sample Input

1 0 1 2 0 0 
1 0 0 0 1 1 
0 0 0 0 0 0 

Sample Output

Collection #1:
Can't be divided.

Collection #2:
Can be divided.


给六种宝石,价值分别是1 2 3 4 5 6,题中input给的是各个宝石的数量,要求的是能不能将这些数量的宝石,分成等价值的两堆。

要是别人不告诉我这是动态规划题,我真想不出这种思路。

头一次见过这种思路,求整体能不能分开,是看其一半值total在数组DP[total]中是不是为true,说是动态规划,其动态规划就体现在在取第n轮宝石时,只跟n-1轮宝石的值有关,这和POJ2392那道题的思路很类似很类似。只要理解思路,写出代码就不难了。

代码:

<span style="font-size:14px;">#include <iostream>
#include <vector>
using namespace std;

int dp[8][120002];//dp[i][j]代表选第i中宝石时,j是否可能取到
//dp[i][j]=dp[i-1][j-i*x]
int marible[8];
int total=0;

void init()
{
	int count;
	total=0;
	for(count=1;count<=6;count++)
	{
		cin>>marible[count];
		total += marible[count]*count;
	}
}

void cal()
{
	int i,j,x;

	memset(dp,0,sizeof(dp));
	dp[1][0]=1;
	for(i=1;i<=marible[1];i++)
		dp[1][i]=1;

	for(i=2;i<=6;i++)
	{
		for(j=0;j<=total;j++)
		{
			if(dp[i-1][j])
			{
				for(x=1;x<=marible[i];x++)
				{
					dp[i][j+x*i]=dp[i-1][j];
				}
			}
			if(dp[i][j])
				continue;
			dp[i][j]=dp[i-1][j];

		}
	}

}

int main()
{
	bool end = true;
	int t=0;
	while(end)
	{
		t++;

		init();
		if(total==0)
		{
			return 0;
		}
		if(total%2)
		{
			cout<<"Collection #"<<t<<":"<<endl;
			cout<<"Can't be divided."<<endl<<endl;
		}
		else
		{
			total /=2;
			cal();
			if(dp[6][total])
			{	
				cout<<"Collection #"<<t<<":"<<endl;
				cout<<"Can be divided."<<endl<<endl;
			}
			else
			{
				cout<<"Collection #"<<t<<":"<<endl;
				cout<<"Can't be divided."<<endl<<endl;
			}
		}
	}
	return 0;
}</span>




版权声明:本文为博主原创文章,未经博主允许不得转载。

原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785892.html