POJ 1961:Period

Period
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 14280 Accepted: 6773

Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input
The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it.

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input
3
aaa
12
aabaabaabaab
0

Sample Output
Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

POJ2406与这道题一个意思,就是这道题细化了一点。

代码:

#include <iostream>
#include <vector>
#include <string>
#include <cstring>
#include <algorithm>
using namespace std;

char a[1000005];
int next1[1000005];

void cal()
{
    int len = strlen(a);
    int i,j=-1;
    next1[0]=-1;
    for(i=0;i<len;)
    {
        if(j==-1||a[i]==a[j])
        {
            i++;
            j++;

            next1[i]=j;
        }
        else
        {
            j=next1[j];
        }
    }
}

int main()
{
    int len,count=1;
    while(cin>>len)
    {
        if(len==0)
            break;

        cin>>a;
        cal();

        int i;
        cout<<"Test case #"<<count++<<endl;

        for(i=2;i<=len;i++)
        {
            if(i%(i-next1[i])==0 && i/(i-next1[i])>=2)
                cout<<i<<" "<<i/(i-next1[i])<<endl;
        }

        cout<<endl;
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785873.html