POJ 1050:To the Max

To the Max
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 43241   Accepted: 22934

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

题意是给定一个矩阵,求其子矩阵的最大和。

这题也是弄得相当郁闷,一开始暴力,结果预料之中的TLE。然后试了一下dp,结果还MLE。。。郁闷得不行。

然后看了别人的思路,发现可以二维变一维,想了想忽然恍然大悟。

将每一列的加起来,就是一维了。枚举不同行即可。之前怎么做的这次怎么求。

代码:

#include <iostream>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#pragma warning(disable:4996) 
using namespace std;

int value[250][250];
int value2[250];
int dp[250];

int main()
{
	//freopen("input.txt","r",stdin);
	//freopen("out.txt","w",stdout);

	int N,i,j,h,k,g,f;
	int ans=-100;
	scanf("%d",&N);

	memset(dp,0,sizeof(dp));
	memset(value2,0,sizeof(value2));

	for(i=1;i<=N;i++)
	{
		for(j=1;j<=N;j++)
		{
			scanf("%d",&value[i][j]);
			ans=max(ans,value[i][j]);
		}
	}

	for(i=1;i<=N;i++)
	{
		for(h=i;h<=N;h++)
		{
			for(k=1;k<=N;k++)
			{	
				value2[k] += value[h][k];
				dp[k] = max(dp[k-1]+value2[k],value2[k]);
				ans = max(ans,dp[k]);
			}
			memset(dp,0,sizeof(dp));
		}
		memset(value2,0,sizeof(value2));
	}

	cout<<ans<<endl;
	return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785843.html