POJ 3087:Shuffle'm Up

Shuffle'm Up
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7364   Accepted: 3408

Description

A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:

The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.

For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

Output

Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

Sample Input

2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC

Sample Output

1 2
2 -1


题意就是给了两副牌,然后洗牌,洗牌规则给出见图。问洗多少次能达到目标牌,如果达不到就输出-1。

这道题为什么放在了广搜里面?就是一直洗,要么到了目标牌,要么出现了之前洗过的牌,输出-1。

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <map>
#include <string>
#include <cstring>
#pragma warning(disable:4996)
using namespace std;

map<string,int> meet;
int Test,i,i1,num;
string s1,s2,dis;

string shuffle(string t1,string t2)
{
	string re="";
	for(i=0;i<num;i++)
	{
		re += t2[i];
		re += t1[i];
	}
	return re;
}

int cal()
{
	string temp=shuffle(s1,s2);
	meet[temp]=1;
	string temp1,temp2,temp3;
	while(1)
	{
		if(temp==dis)
			return meet[temp];
		temp1=temp.substr(0,num);
		temp2=temp.substr(num,num);

		temp3=shuffle(temp1,temp2);
		if(meet[temp3])
			return -1;
		else
			meet[temp3]=meet[temp]+1;
		temp=temp3;
	}
}

int main()
{
	//freopen("i.txt","r",stdin);
	//freopen("o.txt","w",stdout);

	cin>>Test;
	
	for(i1=1;i1<=Test;i1++)
	{
		cin>>num;
		cin>>s1>>s2;
		cin>>dis;

		cout<<i1<<" "<<cal()<<endl;
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785821.html