POJ 1837:Balance 天平DP。。。

Balance
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 11878   Accepted: 7417

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm); 
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2

题意是给了一个秤,然后给你几个点的位置用来放秤砣,负号代表在秤的左边,正好代表在秤的右边。

然后又给了几个秤砣,给了秤砣的重量。题目求的是用这些秤砣有多少种平衡方案。

读完题根本没感觉这是一道DP题。。。后来看得多了才发现应该看到这么小的数值 就想到枚举状态,这样逐渐往下推的DP,好歹这样题也不少了,什么分1 2 3 4 5 6石头的,都是这种思想。

这题也是用DP[i][j]表示放置第i个秤砣 秤的状态是j时的方案。

秤的状态通过计算15*25*20,即最远能到达7500。左右都是,即应该-7500到7500。但因为数组下标一定是大于等于零的,所以就用0~15000表示。

DP[0][7500]=1表示一个秤砣都没放时,状态在平衡状态,且只有一种平衡方案。

然后就是。。。(我其实更愿意把它说成是枚举。。。)往下推。

核心代码:

	for(i=1;i<=G;i++)
	{
		for(j=0;j<=15000;j++)
		{
			for(k=1;k<=C;k++)
			{
				dp[i][j] += dp[i-1][j-weight[i]*weizhi[k]];
			}
		}
	}

即对每一个给定的秤砣不断枚举其原来的状态,不断枚举其所在位置,导致这次能达到的状态。

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string>
#include <cstring>
#pragma warning(disable:4996)
using namespace std;
//最大的状态也就是所有的砝码都放在了最端点的位置
//即20*25*15=7500 即-7500~7500

int dp[21][15001];
int weizhi[21];
int weight[21];

int main()
{

	memset(dp,0,sizeof(dp));
	dp[0][7500]=1;
	int C,G,i,j,k;
	cin>>C>>G;

	for(i=1;i<=C;i++)
		cin>>weizhi[i];
	for(i=1;i<=G;i++)
		cin>>weight[i];
	
	for(i=1;i<=G;i++)
	{
		for(j=0;j<=15000;j++)
		{
			for(k=1;k<=C;k++)
			{
				dp[i][j] += dp[i-1][j-weight[i]*weizhi[k]];
			}
		}
	}
	
	cout<<dp[G][7500]<<endl;
	return 0;
}





版权声明:本文为博主原创文章,未经博主允许不得转载。

原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785786.html