POJ 1979:Red and Black

Red and Black
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 26058   Accepted: 14139

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
给一张图,@为起始点,'.'能走,‘#’不能走,问一共能走到多少'.'。

在深夜能做到这种水题也真是很令人高兴的事情。

深度搜索水题。

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string>
#include <cstring>
#pragma warning(disable:4996)
using namespace std;

int row,col,sum;
char value[30][30];
int flag[30][30];

void dfs(int x,int y)
{
	flag[x][y]=1;
	
	if(x>1&&flag[x-1][y]==0&&value[x-1][y]=='.')
	{
		dfs(x-1,y);
	}
	if(y>1&&flag[x][y-1]==0&&value[x][y-1]=='.')
	{
		dfs(x,y-1);
	}
	if(x<row&&flag[x+1][y]==0&&value[x+1][y]=='.')
	{
		dfs(x+1,y);
	}
	if(y<col&&flag[x][y+1]==0&&value[x][y+1]=='.')
	{
		dfs(x,y+1);
	}
}

void solve1()
{
	int i,j;
	for(i=1;i<=row;i++)
	{
		for(j=1;j<=col;j++)
		{
			if(value[i][j]=='@')
			{
				dfs(i,j);
				return;
			}
		}
	}
}

void solve2()
{
	int i,j;
	for(i=1;i<=row;i++)
	{
		for(j=1;j<=col;j++)
		{
			if(flag[i][j])
			{
				sum++;
			}
		}
	}
}

int main()
{
	int i,j;
	while(cin>>col>>row)
	{
		if(col+row==0)
			break;
		memset(flag,0,sizeof(flag));
		sum=0;
		for(i=1;i<=row;i++)
		{
			cin>>value[i]+1;
		}
		solve1();
		solve2();

		cout<<sum<<endl;
	}

	return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785780.html