hdu 5023 线段树染色问题

题目链接
A Corrupt Mayor’s Performance Art
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 100000/100000 K (Java/Others)
Total Submission(s): 4094 Accepted Submission(s): 1418

Problem Description
Corrupt governors always find ways to get dirty money. Paint something, then sell the worthless painting at a high price to someone who wants to bribe him/her on an auction, this seemed a safe way for mayor X to make money.

Because a lot of people praised mayor X’s painting(of course, X was a mayor), mayor X believed more and more that he was a very talented painter. Soon mayor X was not satisfied with only making money. He wanted to be a famous painter. So he joined the local painting associates. Other painters had to elect him as the chairman of the associates. Then his painting sold at better price.

The local middle school from which mayor X graduated, wanted to beat mayor X’s horse fart(In Chinese English, beating one’s horse fart means flattering one hard). They built a wall, and invited mayor X to paint on it. Mayor X was very happy. But he really had no idea about what to paint because he could only paint very abstract paintings which nobody really understand. Mayor X’s secretary suggested that he could make this thing not only a painting, but also a performance art work.

This was the secretary’s idea:

The wall was divided into N segments and the width of each segment was one cun(cun is a Chinese length unit). All segments were numbered from 1 to N, from left to right. There were 30 kinds of colors mayor X could use to paint the wall. They named those colors as color 1, color 2 … color 30. The wall’s original color was color 2. Every time mayor X would paint some consecutive segments with a certain kind of color, and he did this for many times. Trying to make his performance art fancy, mayor X declared that at any moment, if someone asked how many kind of colors were there on any consecutive segments, he could give the number immediately without counting.

But mayor X didn’t know how to give the right answer. Your friend, Mr. W was an secret officer of anti-corruption bureau, he helped mayor X on this problem and gained his trust. Do you know how Mr. Q did this?

Input
There are several test cases.

For each test case:

The first line contains two integers, N and M ,meaning that the wall is divided into N segments and there are M operations(0 < N <= 1,000,000; 0<M<=100,000)

Then M lines follow, each representing an operation. There are two kinds of operations, as described below:

  1. P a b c
    a, b and c are integers. This operation means that mayor X painted all segments from segment a to segment b with color c ( 0 < a<=b <= N, 0 < c <= 30).

  2. Q a b
    a and b are integers. This is a query operation. It means that someone asked that how many kinds of colors were there from segment a to segment b ( 0 < a<=b <= N).

Please note that the operations are given in time sequence.

The input ends with M = 0 and N = 0.

Output
For each query operation, print all kinds of color on the queried segments. For color 1, print 1, for color 2, print 2 … etc. And this color sequence must be in ascending order.

Sample Input
5 10
P 1 2 3
P 2 3 4
Q 2 3
Q 1 3
P 3 5 4
P 1 2 7
Q 1 3
Q 3 4
P 5 5 8
Q 1 5
0 0

Sample Output
4
3 4
4 7
4
4 7 8

Source
2014 ACM/ICPC Asia Regional Guangzhou Online

考虑到题目说的颜色只有30种,我们可以用一个二进制数来表示演的二进制数的第k位是一就代表它是第k种颜色。
说是线段树染色,但是具体跟线段树求和没什么太大区别,就是把
push_up中的 + 号变成了 | 符号

#include<iostream>
#include<cstdio>
#define mid ((l + r) >> 1)//宏定义的mid注意最外面要有括号
#define lson rt << 1, l, mid//左子树
#define rson rt << 1 | 1, mid + 1, r//右子树
#define ls rt << 1//左子树下标
#define rs rt << 1 | 1//右子树下标
#define tag tree[rt].lazy//简化lazy标记
using namespace std;
const int N = 4e6 + 10;
struct Tree {
	int color, lazy;
}tree[N];
int n, m;
void push_down(int rt) {
	if(tag) {
		tree[ls].color = tree[rs].color = tag;
		tree[ls].lazy = tree[rs].lazy = tag;
		tag = 0;
	}
}
void push_up(int rt) {
	tree[rt].color = tree[ls].color | tree[rs].color;
}
void build(int rt, int l, int r) {
	tree[rt].lazy = 0;//注意lazy标记位0
	if(l == r) {
		tree[rt].color = 1 << 1;//初始化1 << (2 - 1)
		return ;
	}
	build(lson);
	build(rson);
	push_up(rt);
}
void update(int rt, int l, int r, int L, int R, int k) {
	if(l >= L && r <= R) {
		tree[rt].color = 1 << (k - 1);
		tree[rt].lazy = 1 << (k - 1);
		return ;
	}
	push_down(rt);
	if(L <= mid)	update(lson, L, R, k);
	if(R > mid)	update(rson, L, R, k);
	push_up(rt);
}
int query(int rt, int l, int r, int L, int R) {
	if(l >= L && r <= R)
		return tree[rt].color;
	push_down(rt);
	int a = 0;
	if(L <= mid)	a |= query(lson, L, R);
	if(R > mid)	a |= query(rson, L, R);
	return a;	
}
int main() {
	char op;
	int x, y, k;
	while(scanf("%d %d", &n, &m) && (n + m)) {
		build(1, 1, n);
		for(int i = 0; i < m; i++) {
			getchar();
			scanf("%c", &op);
			if(op == 'P') {
				scanf("%d %d %d", &x, &y, &k);
				update(1, 1, n, x, y, k);
			}
			else {
				scanf("%d %d", &x, &y);
				int state = query(1, 1, n, x, y);//得到当前询问段落的颜色二进制数
				int ans = 0;
				bool isfirst = false;//输出格式每行最后面没有空格
				for(int i = 0; i < 30; i++)//从小到大开始判断位数是不是1
					if(state >> i & 1)
						if(isfirst)
							printf(" %d", i + 1);//输出应该是位数 i + 1
						else {
							isfirst = true;
							printf("%d", i + 1);
						}
				puts("");//文段输出换行
			}
		}
	}
	return 0;
}
原文地址:https://www.cnblogs.com/lifehappy/p/12601173.html