HDU A + B Problem II(高精度大数相加)(java版)

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 112635    Accepted Submission(s): 2133

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2

1 2

112233445566778899 998877665544332211

Sample Output

Case 1:

1 + 2 = 3

 

Case 2:

112233445566778899 + 998877665544332211 = 1111111111111111110

解题报告:

这个题用Java写挺简单的,java库里有大整数加法的运算,相当于直接调用即可,

代码如下:

import java.math.BigInteger;
import java.util.Scanner;
public class Main{
    public static void main (String[] args) {
        BigInteger a, b;
        Scanner scan = new Scanner(System.in);
        int n, i;
        n = scan.nextInt();
        for(i = 1; i <= n; ++i){
            a = scan.nextBigInteger();
            b = scan.nextBigInteger();
            System.out.println("Case " + i +":");
            System.out.println(a + " + " + b + " = " + a.add(b));
            if (i < n){
                System.out.println();
            }
        }
    }
}
原文地址:https://www.cnblogs.com/lidaojian/p/2510609.html