POJ 3616 Milking Time(简单DP)

Milking Time

Time Limit: 1000MS

 

Memory Limit: 65536K

Total Submissions: 3055

 

Accepted: 1281

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2

1 2 8

10 12 19

3 6 24

7 10 31

Sample Output

43

Source

USACO 2007 November Silver

 解题报告:这道题就是怎么安排牛的顺序才能效率最大,如果没有效率的话,感觉有点像活动安排,但是加了效率,就得用数组记录记录当前的状态了,自然想到了用DP,先按活动的结束时间从小到大排序,再动态规划即可!

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#define Max(a, b)(a > b ? a : b)
using namespace std;
const int MAX = 1010;
int dp[MAX];
struct Cow//记录牛的信息
{
    int start;
    int end;
    int eff;
}cow[MAX];
int cmp(const void *a, const void *b)//结构体一级排序,按结束时间从小到大排序
{
    return (*(Cow *)a).end - (*(Cow *)b).end;
}
int N, M, R;
int main()
{
    int i, j;
    scanf("%d%d%d", &N, &M, &R);
    for (i =0; i < M; ++i)
    {
        scanf("%d%d%d", &cow[i].start, &cow[i].end, &cow[i].eff);
    }
    qsort(cow, M, sizeof(cow[0]), cmp);
    for (i = 0; i < M; ++i)//初始化
    {
        dp[i] = cow[i].eff;
    }
    for (i = 0; i < M; ++i)
    {
        for (j = i + 1; j < M; ++j)
        {
            if (cow[j].start >= cow[i].end + R)
            {
                dp[j] = Max(dp[i] + cow[j].eff, dp[j]);
            }
        }
    }
    int ans = 0;
    for (i = 0; i < M; ++i)//找到最大的
    {
        if (ans < dp[i])
        {
            ans = dp[i];
        }
    }
    printf("%d\n", ans);
    return 0;
}
        
原文地址:https://www.cnblogs.com/lidaojian/p/2495048.html