POJ 3663 Costume Party (快速排序)

Costume Party

Time Limit: 1000MS

 

Memory Limit: 65536K

Total Submissions: 9132

 

Accepted: 3552

Description

It's Halloween! Farmer John is taking the cows to a costume party, but unfortunately he only has one costume. The costume fits precisely two cows with a length of (1 ≤ S ≤ 1,000,000). FJ has N cows (2 ≤ N ≤ 20,000) conveniently numbered 1..N; cow i has length Li (1 ≤ Li ≤ 1,000,000). Two cows can fit into the costume if the sum of their lengths is no greater than the length of the costume. FJ wants to know how many pairs of two distinct cows will fit into the costume.

Input

* Line 1: Two space-separated integers: N and S
* Lines 2..N+1: Line i+1 contains a single integer: Li

Output

* Line 1: A single integer representing the number of pairs of cows FJ can choose. Note that the order of the two cows does not matter.

Sample Input

4 6

3

5

2

1

Sample Output

4

Source

USACO 2008 January Bronze

 解题报告:这道题就是让求两牛之间的距离小于等于s的个数,直接遍历找的话TEL,先利用快排从小到大排序, 再遍历同时缩小遍历的范围;

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
using namespace std;
const int MAX = 20010;
int a[MAX], n, s, ans;
int main()
{
    int i, j;
    while (scanf("%d%d", &n, &s) != EOF)
    {
        for (i = 0; i < n; ++i)
        {
            scanf("%d", &a[i]);
        }
        ans = 0;
        sort(a, a + n);
        int temp = n;
        for (i = 0; i < temp; ++i)
        {
            for (j = i + 1; j < temp; ++j)
            {
                if (a[i] + a[j] <= s)
                {
                    ans++;
                }
                else
                {
                    temp = j;//缩短遍历的范围
                    break;
                }
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}
原文地址:https://www.cnblogs.com/lidaojian/p/2486155.html