POJ 1265 Area(计算几何Pick定理)

Area

Time Limit: 1000MS

 

Memory Limit: 10000K

Total Submissions: 3131

 

Accepted: 1486

Description

Being well known for its highly innovative products, Merck would definitely be a good target for industrial espionage. To protect its brand-new research and development facility the company has installed the latest system of surveillance robots patrolling the area. These robots move along the walls of the facility and report suspicious observations to the central security office. The only flaw in the system a competitor抯 agent could find is the fact that the robots radio their movements unencrypted. Not being able to find out more, the agent wants to use that information to calculate the exact size of the area occupied by the new facility. It is public knowledge that all the corners of the building are situated on a rectangular grid and that only straight walls are used. Figure 1 shows the course of a robot around an example area. 

                                                               

Figure 1: Example area. 


You are hired to write a program that calculates the area occupied by the new facility from the movements of a robot along its walls. You can assume that this area is a polygon with corners on a rectangular grid. However, your boss insists that you use a formula he is so proud to have found somewhere. The formula relates the number I of grid points inside the polygon, the number E of grid points on the edges, and the total area A of the polygon. Unfortunately, you have lost the sheet on which he had written down that simple formula for you, so your first task is to find the formula yourself. 

Input

The first line contains the number of scenarios. 
For each scenario, you are given the number m, 3 <= m < 100, of movements of the robot in the first line. The following m lines contain pairs 揹x dy�of integers, separated by a single blank, satisfying .-100 <= dx, dy <= 100 and (dx, dy) != (0, 0). Such a pair means that the robot moves on to a grid point dx units to the right and dy units upwards on the grid (with respect to the current position). You can assume that the curve along which the robot moves is closed and that it does not intersect or even touch itself except for the start and end points. The robot moves anti-clockwise around the building, so the area to be calculated lies to the left of the curve. It is known in advance that the whole polygon would fit into a square on the grid with a side length of 100 units. 

Output

The output for every scenario begins with a line containing 揝cenario #i:� where i is the number of the scenario starting at 1. Then print a single line containing I, E, and A, the area A rounded to one digit after the decimal point. Separate the three numbers by two single blanks. Terminate the output for the scenario with a blank line.

Sample Input

2
4
1 0
0 1
-1 0
0 -1
7
5 0
1 3
-2 2
-1 0
0 -3
-3 1
0 -3

Sample Output

Scenario #1:
0 4 1.0
 
Scenario #2:
12 16 19.0

Source

Northwestern Europe 2001

 解题报告:题意就是在一个单位方格的图形中有个多边形,统计在多边形内部点的个数、边上点的个数以及多边形所围成图形的面积,利用Pick定理:多边形的面积、内部的点、及边上的点的关系满足area = in + on / 2 - 1(pick定理);注意要用C++提交AC,用G++交WA!额也不知道怎地!哎!

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
using namespace std;
const int MAX = 105;
int m, n, on, in;
double area;
struct node
{
    int x, y;
}point[MAX];
int Gcd(int a, int b)//求a和b的最大公约数的函数
{
    int temp;
    if (a < b)//把a和b中较大的数字放到a中
    {
        temp = a;
        a = b;
        b = temp;
    }
    if (b == 0)//找到两者的最大公约数,直接返回a
    {
        return a;
    }
    return Gcd(b, a % b);//否则继续往下找
}
int Area(int i)//叉积计算多边形的面积
{
    return double(point[i - 1].x * point[i].y - point[i].x * point[i - 1].y);
}
int main()
{
    int i, j, xx, yy;
    scanf("%d", &m);
    for (i = 1; i <= m; ++i)
    {
        printf("Scenario #%d:\n", i);
        scanf("%d", &n);
        memset(point, 0, sizeof(point));
        on = 0;
        in = 0;
        area = 0;
        for (j = 1; j <= n; ++j)
        {
            scanf("%d%d", &xx, &yy);
            point[j].x = xx + point[j - 1].x;
            point[j].y = yy + point[j - 1].y;
            on += Gcd(abs(xx), abs(yy));//求在边上的点的个数
            area += Area(j);
        }
        area = area / 2.0;
        in = int(area) + 1 - on / 2;
        printf("%d %d %.1lf\n", in, on, area);
        printf("\n");
    }
    return 0;
}
原文地址:https://www.cnblogs.com/lidaojian/p/2480885.html