POJ 1035 Spell checker(字符串简单匹配)

Spell checker

Time Limit: 2000MS

 

Memory Limit: 65536K

Total Submissions: 12900

 

Accepted: 4760

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. 
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations: 
?deleting of one letter from the word; 
?replacing of one letter in the word with an arbitrary letter; 
?inserting of one arbitrary letter into the word. 
Your task is to write the program that will find all possible replacements from the dictionary for every given word. 

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary. 
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked. 
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most. 

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i

is

has

have

be

my

more

contest

me

too

if

award

#

me

aware

m

contest

hav

oo

or

i

fi

mre

#

Sample Output

me is correct

aware: award

m: i my me

contest is correct

hav: has have

oo: too

or:

i is correct

fi: i

mre: more me

Source

Northeastern Europe 1998

 解题报告:这道题就是字符串匹配问题,分为四种情况,(1)完全匹配,(2)字符串长度相同只是只有一个字母不相同(3)字符串相差一,比原始字符串少一个字符或多一个字符;

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
using namespace std;
const int N = 10010;
char word[N][20];
int Judge1(char *a, char *b, int len)
{
int i, ans = 0;
for (i = 0; i < len; ++i)
{
if (a[i] != b[i])
{
ans ++;
if (ans > 1)
{
return 0;
}
}
}
return 1;
}
int Judge2(char *a, char *b, int len)//len是字符串a的长度;
{
int i, j, ans = 0;
for (i = 0, j = 0; i < len; ++i)
{
if (a[i] != b[j])
{
ans ++;
j --;
if (ans > 1)
{
return 0;
}
}
j ++;
}
return 1;
}
int main()
{
int i, count, flag, len1, len2;
char c[20];
memset(word, 0, sizeof(word));
count = 0;
while (scanf("%s", word[count]) && strcmp(word[count], "#") != 0)
{
count++;
}
while (scanf("%s", c) && strcmp(c, "#") != 0)
{
printf("%s", c);
flag = 1;
for (i = 0; i < count; ++i)
{
if (strcmp(c, word[i]) == 0)//完全匹配情况
{
printf(" is correct\n");
flag = 0;
break;
}
}
if (flag)
{
printf(":");
len1 = strlen(c);
for(i = 0; i < count; ++i)
{
len2 = strlen(word[i]);
if (len1 == len2 && Judge1(c, word[i], len1))//长度相同,只有一个字符不匹配
{
printf(" %s", word[i]);
}
else if ((len1 - len2 == 1) && Judge2(c, word[i], len1))//长度相差一,比原始字符串多一个
{
printf(" %s", word[i]);
}
else if ((len2 - len1 == 1) && Judge2(word[i], c, len2))//长度相差一,比原始字符串少一个
{
printf(" %s", word[i]);
}
}
printf("\n");
}
}
return 0;
}



原文地址:https://www.cnblogs.com/lidaojian/p/2396658.html