HDU 2374 || SDUT2386 A Game with Marbles(简单题)

A Game with Marbles

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 611    Accepted Submission(s): 339

Problem Description

There are n bowls, numbered from 1 to n. Initially, bowl i contains mi marbles. One game step consists of removing one marble from a bowl. When removing a marble from bowl i (i > 1), one marble is added to each of the first i-1 bowls; if a marble is removed from bowl 1, no new marble is added. The game is finished after each bowl is empty.

Your job is to determine how many game steps are needed to finish the game. You may assume that the supply of marbles is sufficient, and each bowl is large enough, so that each possible game step can be executed. 

Input

The input contains several test cases. Each test case consists of one line containing one integer n (1 ≤ n ≤ 50), the number of bowls in the game. The following line contains n integers mi (1 ≤ i ≤ n, 0 ≤ mi ≤ 1000), where mi gives the number of marbles in bowl i at the beginning of the game. 

The last test case is followed by a line containing 0. 

 

Output

For each test case, print one line with the number of game steps needed to finish the game. You may assume that this number fits into a signed 64-bit integer.

 

Sample Input

10

3 3 3 3 3 3 3 3 3 3

5

1 2 3 4 5

0

Sample Output

3069

129

Source

2008水题公开赛(比速度,OJ压力测试)

 

Recommend

lcy

 

解题报告:这道题读懂了就好做了,就是若移第i个碗的每一个大理石时,它前面的全部加1,即移完第i个碗中的大理石,它前面的每个碗中增加的的碗数就是第i个碗中的大理石,问移到第一个碗中最少需要多少步,就是从最后的碗中向前移即可!

代码如下:

#include <stdio.h>
__int64 a[1010], ans;
int main()
{
int n, i, j;
while(scanf("%d", &n) != EOF && n)
{
for (i = 1; i <= n; ++i)
{
scanf("%I64d", &a[i]);
}
ans = 0;
for (i = n; i >= 1; --i)
{
ans += a[i];
for(j = i- 1; j >=1; --j)//让i前面的全部加上a[i],表示把第i个碗中的大理石全部移完
{
a[j] += a[i];
}
}
printf("%I64d\n", ans);
}
return 0;
}



原文地址:https://www.cnblogs.com/lidaojian/p/2380871.html