HDU 2368 ||SDUT 2380 Alfredo's Pizza Restaurant(水题)

Alfredo's Pizza Restaurant

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 950    Accepted Submission(s): 562

Problem Description

Traditionally after the Local Contest, judges and contestants go to their favourite restaurant, Alfredos Pizza Restaurant. The contestants are really hungry after trying hard for five hours. To get their pizza as quickly as possible, they just decided to order one big pizza for all instead of several small ones. They wonder whether it is possible to put the big rectangular pizza on the surface of the round table such that it does not overhang the border of the table. Write a program that helps them!

 

Input

The input file contains several test cases. Each test case starts with an integer number r, the radius of the surface of the round table the contestants are sitting at. Input is terminated by r=0. Otherwise, 1 ≤ r ≤ 1000. Then follow 2 integer numbers w and l specifying the width and the length of the pizza, 1 ≤ w ≤ l ≤ 1000. 

Output

Output for each test case whether the ordered pizza will fit on the table or not. Adhere to the format shown in the sample output. A pizza which just touches the border of the table without intersecting it is considered fitting on the table, see example 3 for clarification. 

Sample Input

38 40 60

35 20 70

50 60 80

0

Sample Output

Pizza 1 fits on the table.

Pizza 2 does not fit on the table.

Pizza 3 fits on the table.

Source

2008水题公开赛(比速度,OJ压力测试)

 

Recommend

lcy

解题报告:有一个圆桌,看饼是否能完全放在上面,一道水题;

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{
double r, w, l;
int count = 1;
while(scanf("%lf", &r) != EOF && r)
{
scanf("%lf%lf", &w, &l);
r = 2 * r;
printf("Pizza %d ", count);
count ++;
if(w * w + l * l <= r * r)
{
printf("fits on the table.\n");
}
else
{
printf("does not fit on the table.\n");
}
}
return 0;
}



原文地址:https://www.cnblogs.com/lidaojian/p/2379589.html