HDU1398 Square Coins(母函数)

Square Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4089    Accepted Submission(s): 2782

Problem Description

People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland. 
There are four combinations of coins to pay ten credits: 
ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin. 
Your mission is to count the number of ways to pay a given amount using coins of Silverland.

Input

The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.

Output

For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output. 

Sample Input

2

10

30

0

 

Sample Output

1

4

27

Source

Asia 1999, Kyoto (Japan)

Recommend

Ignatius.L

解题报告:题意和HDU1028差不多但是这个题限制了只能是一个数的平方

例如第二个样例10的拆分数是这样算出来的就是求:

(1+x+x^2+x^3+x^4+x^5+x^6+x^7+x^8+x^9+x^10)(1+x^4+x^8)(1+x^9)中

x^10的系数即可,也是套用母函数模板,只是把把i<=n改成了i*i<=n,

在k遍历指数时把k=k+i变成了k=k+i*i(因为指数增加的时候是“相加“型,

例:x^9*x^27=x^36);就AC了!

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
const int N = 310;
int c1[N],c2[N];
int main()
{
int n,i,j,k;
while(scanf("%d",&n)!=EOF&&n)
{
for(i=0;i<=n;i++)
{
c1[i]=1;
c2[i]=0;
}
for(i=2;i*i<=n;i++)
{
for(j=0;j<=n;j++)
{
for(k=0;k+j<=n;k=k+i*i)
{
c2[k+j]=c2[k+j]+c1[j];
}
}
for(j=0;j<=n;j++)
{
c1[j]=c2[j];
c2[j]=0;
}
}
printf("%d\n",c1[n]);
}
return 0;
}



原文地址:https://www.cnblogs.com/lidaojian/p/2264639.html