Uva 340 MasterMind Hints

Master-Mind Hints 

MasterMind is a game for two players. One of them, Designer, selects a secret code. The other, Breaker, tries to break it. A code is no more than a row of colored dots. At the beginning of a game, the players agree upon the length N that a code must have and upon the colors that may occur in a code.

In order to break the code, Breaker makes a number of guesses, each guess itself being a code. After each guess Designer gives a hint, stating to what extent the guess matches his secret code.

In this problem you will be given a secret code tex2html_wrap_inline35 and a guess tex2html_wrap_inline37 , and are to determine the hint. A hint consists of a pair of numbers determined as follows.

match is a pair (i,j), tex2html_wrap_inline41 and tex2html_wrap_inline43 , such that tex2html_wrap_inline45 . Match (i,j) is called strong when i =j, and is called weak otherwise. Two matches (i,j) and (p,q) are called independent when i = p if and only if j = q. A set of matches is called independent when all of its members are pairwise independent.

Designer chooses an independent set M of matches for which the total number of matches and the number of strong matches are both maximal. The hint then consists of the number of strong followed by the number of weak matches in M. Note that these numbers are uniquely determined by the secret code and the guess. If the hint turns out to be (n,0), then the guess is identical to the secret code.

Input

The input will consist of data for a number of games. The input for each game begins with an integer specifying N (the length of the code). Following these will be the secret code, represented as N integers, which we will limit to the range 1 to 9. There will then follow an arbitrary number of guesses, each also represented as N integers, each in the range 1 to 9. Following the last guess in each game will be N zeroes; these zeroes are not to be considered as a guess.

Following the data for the first game will appear data for the second game (if any) beginning with a new value for N. The last game in the input will be followed by a single zero (when a value for N would normally be specified). The maximum value for N will be 1000.

Output

The output for each game should list the hints that would be generated for each guess, in order, one hint per line. Each hint should be represented as a pair of integers enclosed in parentheses and separated by a comma. The entire list of hints for each game should be prefixed by a heading indicating the game number; games are numbered sequentially starting with 1. Look at the samples below for the exact format.

Sample Input

4
1 3 5 5
1 1 2 3
4 3 3 5
6 5 5 1
6 1 3 5
1 3 5 5
0 0 0 0
10
1 2 2 2 4 5 6 6 6 9
1 2 3 4 5 6 7 8 9 1
1 1 2 2 3 3 4 4 5 5
1 2 1 3 1 5 1 6 1 9
1 2 2 5 5 5 6 6 6 7
0 0 0 0 0 0 0 0 0 0
0

Sample Output

Game 1:
    (1,1)
    (2,0)
    (1,2)
    (1,2)
    (4,0)
Game 2:
    (2,4)
    (3,2)
    (5,0)
    (7,0)



// Address:Uva 340 - Master-Mind Hints(猜数字) 
// level: easy
// Classify:数组 
// Verdict: Accepted [one times] 
// UVa Run Time: 0.004s 
// Submission Date: 2012-12-6 7:58:02  
// My ID: xueying 
// Usetime:1 hours
// [解题方法]  
// 对于本体来说,理解题意是一个问题,但因为与一个游戏相似,借鉴simple还是能看出题意来 
// 计算guess和code中位置和数字相同的code的数量(即为题目所说的strong,用数组实现),
// 至于怎样计算weak, 题目说明所有的 Code的范围在1~9之间,开两个大小为10的数组分别存储code和目前guess 
// 中1~9出现的次数, 遍历过后得code和guess中0~9每个数字出现的次数,对于各个数(0~9),在这两个
// 数组比较,取出现次数少的数相加,得到的sum减去strong就得到weak。 
 
#include<stdio.h>
#include<string.h>
int code[1002], guess[1002];

int main()
{
    int n, i, j, len, m, strong, weak, T = 0, flag, t, tcode[10], tguess[10];
    while(scanf("%d", &n) == 1 && n)
    {
        t = 0, T++;  // t的作用是判断是否需要输出“Game #”样式,T是“#”的值 
        memset(code, 0, sizeof(code));
        for(i=0; i<n; ++i) scanf("%d", &code[i]);

        while(1)
        {
            memset(guess, 0, sizeof(guess));
            flag = strong = weak = 0;
            for(i=0; i<n; ++i) 
            {
                scanf("%d", &guess[i]);
                if(guess[i] != 0) flag = 1; // 判断guess结束的标记 
            }
            if(!flag) break;
            else
            {
                memset(tcode, 0, sizeof(tcode));
                memset(tguess, 0, sizeof(tguess));
                
                if(t++ == 0) printf("Game %d:\n", T);
                for(i=0; i<n; ++i) 
                {// 统计strong的值的同时,统计在code和guess中各个数字(0~9)出现的次数 
                    if(guess[i] == code[i]) strong++;
                    tcode[(code[i])] = tcode[(code[i])] + 1; // 简化的话,可以在输入code时统计 
                    tguess[(guess[i])] = tguess[(guess[i])] + 1;
                }
                for(i=1; i<=9; ++i)
                {
                    m = tcode[i] > tguess[i] ? tguess[i] : tcode[i];  // 取两个数组中i(0~9)出现次数少的数 
                    weak = weak + m;  // 进行统计 
                }
                weak = weak - strong;  // 得出weak的值 
                printf("    (%d,%d)\n", strong, weak);
            }
        }
    }
        
return 0;        
}
原文地址:https://www.cnblogs.com/liaoguifa/p/2804336.html