Uva 101 The Blocks Problem

 The Blocks Problem 

 Time limit: 3.000 seconds

Background 

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks.

In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will ``program'' a robotic arm to respond to a limited set of commands.

 

The Problem 

The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are n blocks on the table (numbered from 0 to n-1) with block bi adjacent to block bi+1 for all $0 \leq i < n-1$ as shown in the diagram below:

 
\begin{figure}
\centering
\setlength{\unitlength}{0.0125in} %
\begin{picture}
(2...
...raisebox{0pt}[0pt][0pt]{$\bullet
\bullet \bullet$ }}}
\end{picture}
\end{figure}
Figure: Initial Blocks World

The valid commands for the robot arm that manipulates blocks are:

  • move a onto b

    where a and b are block numbers, puts block a onto block b after returning any blocks that are stacked on top of blocks a and b to their initial positions.

  • move a over b

    where a and b are block numbers, puts block a onto the top of the stack containing block b, after returning any blocks that are stacked on top of block a to their initial positions.

  • pile a onto b

    where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto block b. All blocks on top of block b are moved to their initial positions prior to the pile taking place. The blocks stacked above block a retain their order when moved.

  • pile a over b

    where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto the top of the stack containing block b. The blocks stacked above block aretain their original order when moved.

  • quit

    terminates manipulations in the block world.

Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration of blocks.

 

The Input 

The input begins with an integer n on a line by itself representing the number of blocks in the block world. You may assume that 0 < n < 25.

The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the quit command is encountered.

You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.

 

The Output 

The output should consist of the final state of the blocks world. Each original block position numbered i ($0 \leq i < n$ where n is the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other block numbers by a space. Don't put any trailing spaces on a line.

There should be one line of output for each block position (i.e., n lines of output where n is the integer on the first line of input).

 

Sample Input 

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit

 

Sample Output 

 0: 0
 1: 1 9 2 4
 2:
 3: 3
 4:
 5: 5 8 7 6
 6:
 7:
 8:
 9:

 

 


Miguel Revilla  2000-04-06
 
 
 
 
#include<stdio.h>
#include<string.h>
#include<ctype.h>
char cmd[20], morp[5], roro[5];      //cmd存储输入的指令,morp and roro 截指令 
int block[30], point[30][2];        //block数组存储障碍物, 
                                        //point[i][0]存储它所在的堆,point[i][1]存储所连接的堆 以数组下标存储
                                        

int ifctn(int n, int m)
{//判断指令是否无效,返回0表示有效,返回1表示无效 
    int t;
    t = n;
    while(point[t][1] != t)
    {
        t = point[t][1];
        if(t == m) return 1;
    }
    t = m;
    while(point[t][1] != t)
    {
        t = point[t][1];
        if(t == n) return 1;
    }
    return 0;
}

int del(int n)
{
    int t, k;
    t = k = n;
    while(point[t][1] != t)
    {
        t = point[t][1];
        point[n][1] = n;
        point[t][0] = t;    //不需要处理point[n][0] 
        n = t;
    }
    return 0; 
}

int Traver(int n)
{
    int i, t;
    for(i=0; i<n; ++i)
    {
        printf("%d:", block[i]);
        
        if(point[i][0] == i)
        {
            printf(" %d", block[i]);
            t = i;
            while(point[t][1] != t)
            {
                t = point[t][1];
                printf(" %d", block[t]);
            }
        }
        printf("\n");
    }
    return 0;
}


int main()
{
     int i, j, T, t, n, flag, len, a, b;
    scanf("%d", &n);
    getchar();
    memset(cmd, '\0', sizeof(char)*20);
    memset(morp, '\0', sizeof(morp));
    memset(roro, '\0', sizeof(roro)); 
    for(i=0; i<30; ++i)
    {
        block[i] = i;
        point[i][0] = point[i][1] = i;  //查看是否移除时,直接判断point[i][0] 的值是否为本身 
    } 
    //Traver(n);
    while(fgets(cmd, 20, stdin) != NULL)
    {
        flag = 0;
        len = strlen(cmd);
        if(cmd[len-1] == '\n') cmd[--len] = '\0';
        if(strcmp(cmd, "quit") == 0) break;
        memcpy(morp, cmd, 4*sizeof(char));
        a = cmd[5] - '0';
        if(isdigit(cmd[6])) {a = a*10 + (cmd[6] - '0'); flag = 1;}
         memcpy(roro, cmd+7+flag, 4*sizeof(char));
         b = cmd[12+flag] - '0';
         if(isdigit(cmd[12+flag+1])) b = b*10 + (cmd[12+flag+1] - '0');
    //    printf("%s %d %s %d\n", morp, a, roro, b); 
        if(a == b || ifctn(a, b))continue; 
        if(strcmp(morp, "move") == 0)
        {
            if(strcmp(roro, "onto") == 0)
            {
                if(point[a][1] != a) del(a);
                if(point[a][0] != a) point[(point[a][0])][1] = point[a][0];
                if(point[b][1] != b) del(b);
                point[b][1] = a;
                point[a][0] = b; 
            }
            else 
            {
                t = b;
                while(point[t][1] != t)  t = point[t][1];
                if(point[a][1] != a) del(a);
                if(point[a][0] != a) point[(point[a][0])][1] = point[a][0];
                point[a][0] = t;
                point[t][1] = a;
            }
        }
        else 
        {
            if(strcmp(roro, "onto") == 0)
            {
                if(point[b][1] != b) del(b);
                if(point[a][0] != a) point[(point[a][0])][1] = point[a][0];
                point[b][1] = a;
                point[a][0] = b;
            }
            else 
            {
                t = b;
                while(point[t][1] != t)  t = point[t][1];
                if(point[a][0] != a) point[(point[a][0])][1] = point[a][0];
                point[t][1] = a;
                point[a][0] = t;
            }
        }
    
    }
    Traver(n);
    return 0;
} 


解题思路:

1y,1y过的题目总觉得有点简单,当时理解题目如下截图:

所以,会产生模糊的还是其中一种情况:当其中的一个障碍物上面还有障碍物的时候,而要把这个障碍物移到其他还有障碍物在上方的障碍物上,需不需要将堆在所要移动的障碍物上面的障碍物移回到原来位置?答案是需要的,因为就像上面截图所说的,hint中并没有提到这个问题

可以说这题是我做过最有趣的一道题目

原文地址:https://www.cnblogs.com/liaoguifa/p/2795010.html