Uva 10815 Andy's First Dictionary

Problem B: Andy's First Dictionary

Time limit: 3 seconds


Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful.

You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like "Apple", "apple" or "APPLE" must be considered the same.

 

Input

The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.

 

Output

Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.

 

Sample Input

Adventures in Disneyland

Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: "Disneyland Left."

So they went home.

 

Sample Output

a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when

 


Joke and image taken from the Web
 
#include<stdio.h>
#include<string.h>
#include<ctype.h>
char word[5004][204];
char input[204], temp[204];
int main()
{
    int i, j, T = 0, len, count, flag;
    for(i=0; i<5004; ++i)    memset(word[i], '\0', sizeof(char)*204);
    
    memset(input, '\0', sizeof(char)*204);
    memset(temp, '\0', sizeof(char)*204);
    while(fgets(input, 204, stdin) != NULL)
    {
        flag = count = 0;
        len = strlen(input);
        if(input[len-1] != '\n') input[len++] = '\n';
        for(i=0; i<len; ++i)
        {
            if(isalpha(input[i]) && isupper(input[i])) input[i] =  tolower(input[i]);
            
            if(isalpha(input[i])) 
            {
                temp[count++] = input[i];
                flag = 1;
            }
            else if(flag)
            {
                flag = 0;
                if(!T) {strcpy(word[T], temp); memset(temp, '\0', sizeof(char)*204); T++;}
                else 
                {
                    for(j=0; j<T && strcmp(word[j], temp) != 0; ++j); 
                    if(j >= T) strcpy(word[T++], temp);
                    memset(temp, '\0', sizeof(char)*204);    
                }
                count = 0;
            }
        }
        
        memset(input, '\0', sizeof(char)*204);
        memset(temp, '\0', sizeof(char)*204);
    }
    
    for(i=0; i<T-1; ++i)
    {
        flag = 1;
        for(j=0; j<T-1-i; ++j)
        if(strcmp(word[j], word[j+1]) > 0)
        {
            strcpy(temp, word[j]);
            strcpy(word[j], word[j+1]);
            strcpy(word[j+1], temp);
        }
    }
    for(i=0; i<T; ++i)
    printf("%s\n", word[i]);
    return 0;
}


解题报告:

判断单词,处理大小写,判断是否重复,单词按字典顺序排序

 
 
原文地址:https://www.cnblogs.com/liaoguifa/p/2791888.html