HDU ACM 1157 Who's in the Middle

Who's in the Middle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5253    Accepted Submission(s): 2676

Problem Description
FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less.
Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
 
Input
* Line 1: A single integer N
* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
 
Output
* Line 1: A single integer that is the median milk output.
 
Sample Input
5 2 4 1 3 5
 
Sample Output
3
Hint
INPUT DETAILS: Five cows with milk outputs of 1..5 OUTPUT DETAILS: 1 and 2 are below 3; 4 and 5 are above 3.
 
Source
 
Recommend
mcqsmall
 
#include<stdio.h>
#include<string.h>
int a[10010]; 
int main()
{
    int i, n, temp, j, flag;
    memset(a, 0, sizeof(a));
    while(scanf("%d", &n) != EOF)
    {
    
    for(i=0; i<n; ++i) scanf("%d", &a[i]);
    for(i=0; i<n-1; ++i)
    {
        flag = 0;
        for(j=0; j<n-1-i; ++j)
        if(a[j]>a[j+1])
        {
            flag = 1;
            temp = a[j];
            a[j] = a[j+1];
            a[j+1] = temp;
        }
        if(!flag) break;
    }
    printf("%d\n", a[n/2]);
    memset(a, 0, sizeof(a));
    }
    return 0;
}

简单的排序输出中间值,开始看到那么低的AC率觉得里面有坑人的地方,果然不出我所料,1WA,打击我的自信心不重要,重要的是我的AC率又低了一个档次

 
原文地址:https://www.cnblogs.com/liaoguifa/p/2764957.html