Uva 424 Integer Inquiry

 Integer Inquiry 

Time limit: 3.000 seconds

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670


#include<stdio.h>
#include<string.h>
int main()
{
    int sum[104], e, len, i, j, temp;
    char input[101];
    memset(sum, 0, sizeof(sum));
    memset(input, 0, sizeof(input));
    while(scanf("%s", input) == 1 && input[0])
    {
        getchar();
        e = 0;
        len = strlen(input);
        for(i=0; i<len; ++i)
        {
            temp = sum[i];
            sum[i] = (e + sum[i] + (input[len-i-1]-'0'))%10;
            e = (e + temp + (input[len-i-1]-'0'))/10;
        }
        for(j=i; j<104 && e; ++j)
        {
            temp = sum[j];
            sum[j] = (e + sum[j])%10;
            e = (e + temp)/10;
        }
        memset(input, 0, sizeof(input));
        
    }
    for(i=103, temp = 0; i>=0; --i)
    {
        if(sum[i] != 0)
        {
            temp = 1;
            printf("%d", sum[i]);
        }
        else if(temp == 1)
        {
            printf("%d", sum[i]);
        }
    }
    printf("\n");
    return 0;
}

解题报告:

#高精度加法#

减少WA想一次性AC,那必须要付出点耐心和要有严谨的思维,这题所需要的知识能追溯到一年前,高精度计算对于只是加法来说不是很难,我也没打算说做不出来,

但最后还是WA了三次(但我无动于衷)

1WA:数组开小了,最大的数为100个10的100次方想加再减去100,我开的数组只是102,多开就行了

2WA:是因为改了数组忘了改下面输出时的数组下标,愣着让i=102一直减下去,怪不得1+1会出现6000……00002 <iiiii+ _+ iiiii>这算什么调试啊?

         这问题也只有我能犯!!

3WA:计算后来的进位e顾着复制,把i当作j用了几次,效果还不错陪着我的程序WA了三次,没你哪有后面的AC呢……

复制的东西不可取,当i当作j不值得!!

原文地址:https://www.cnblogs.com/liaoguifa/p/2755787.html