ACM HDU 1014 Uniform Generator

Uniform Generator

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10295 Accepted Submission(s): 4071


Problem Description
Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

seed(x+1) = [seed(x) + STEP] % MOD

where '%' is the modulus operator.

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.
Input
Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).
Output
For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each output test set, your program should print exactly one blank line.
Sample Input
3 5
15 20
63923 99999
Sample Output
3 5 Good Choice 15 20 Bad Choice 63923 99999 Good Choice
Source
 
Recommend
JGShining
 
#include<stdio.h>
#include<string.h>
int num[100002], tried[100002];
int main()
{
    int step, mod;
    int i;
    while(scanf("%d%d", &step, &mod) != EOF)
    {
    memset(num, 0, sizeof(num));
    memset(tried, 0, sizeof(tried));
    for(i=0; i<100002 - 1; i++)
    {
        num[i+1] = (num[i] + step) % mod;
        tried[num[i]] = 1;
        if(num[i+1] == num[0]) break;
    }
    for(i=0; i<mod; i++)
    if(tried[i] == 0) break;
    printf("%10d%10d", step, mod);
    if(i<mod) printf("    Bad Choice\n\n");
    else printf("    Good Choice\n\n");
    }
    return 0;
}

结题报告:

题目长,啃下来已经一段时间了,发现题目确实不难,主要考察什么暂且还是不知道,看看边界条件,开了足够大的数组给它,本打算一次性给它AC的,谨慎了一段时间后

还是很快提交了,很明显的被PE掉了,输出有问题,复制了OutPut的数据才知道自己多了一个space,改后灰头灰面的交上去了,AC!

物役记

更多内容请关注个人微信公众号 物役记 (微信号:materialchains)

原文地址:https://www.cnblogs.com/liaoguifa/p/2701412.html