ACM HDU 1004 Let The Balloon Rise

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 45217 Accepted Submission(s): 16055

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
 
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output
red
pink
 
Author
WU, Jiazhi
Source
 
Recommend
JGShining
 
#include<stdio.h>
#include<string.h>
int main()
{
    char co[1001][16];
    int i, num, max, j, sum[1001];
    char temp[16];
    while(1)
    {
        memset(sum, 0, sizeof(sum));
        max = 0;
        scanf("%d", &num);
        if(num)
        {
            for(i=0; i < num; ++i)
            {
                scanf("%s", temp);
                for(j=0; j<i; j++)
                    if(strcmp(co[j], temp) == 0)break;
                if(j >= i)
                    strcpy(co[j], temp);
                sum[j]++;
                if(sum[max] < sum[j]) max = j;
            }
            printf("%s\n", co[max]);
        }
        else break;
     }
     return 0;
}

解题情况:

TEL的情况是因为在scanf后加上了fflush(stdin),这个问题还搞不懂,只是知道C和C++标准中从无定义过fflush;

WA的情况是因为将memset函数放在了第一for循环后面,忽略了编译器自动将整型数组默认为0。

物役记

更多内容请关注个人微信公众号 物役记 (微信号:materialchains)

原文地址:https://www.cnblogs.com/liaoguifa/p/2698575.html