hdoj_1312Red and Black

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5175    Accepted Submission(s): 3370


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
45 59 6 13

#include <iostream>
#include <cstring>
using namespace std;
#pragma warning(disable : 4996)
#define MAX 25
char maps[MAX][MAX];
int w, h, ans;
const int moves[4][2] = {{0, -1}, {0, 1}, {1, 0}, {-1, 0}};

void dfs(int x, int y)
{
	maps[x][y] = '#';
	for(int i = 0; i < 4; i++)
	{
		int p = x + moves[i][0];
		int q = y + moves[i][1];
		if(p >= 1 && p <= h && q >= 1 && q <= w && maps[p][q] == '.')
		{
			maps[p][q] = '#';
			ans++;
			dfs(p, q);
		}
	}

}

int main()
{
	freopen("in.txt", "r", stdin);
	int x, y;
	while (cin >>w >> h)
	{
		if(w == 0 && h == 0)
		{
			break;
		}
		for(int i = 1; i <= h; i++)
		{
			for(int j = 1; j <= w; j++)
			{
				cin >> maps[i][j];
				if(maps[i][j] == '@')
				{
					x = i;
					y = j;
				}
			}
		}
		ans = 1;
		dfs(x, y);
		cout << ans << endl;
	}
	return 0;
}



原文地址:https://www.cnblogs.com/lgh1992314/p/5835122.html