The Last Practice

http://acm.hdu.edu.cn/diy/contest_showproblem.php?pid=1008&cid=22619




Problem Description

Tomorrow is contest day, Are you all ready?
We have been training for 45 days, and all guys must be tired.But , you are so lucky comparing with many excellent boys who have no chance to attend the Province-Final.

Now, your task is relaxing yourself and making the last practice. I guess that at least there are 2 problems which are easier than this problem.
what does this problem describe?
Give you a positive integer, please split it to some prime numbers, and you can got it through sample input and sample output.

Input

Input file contains multiple test case, each case consists of a positive integer n(1<n<65536), one per line. a negative terminates the input, and it should not to be processed.

Output

For each test case you should output its factor as sample output (prime factor must come forth ascending ), there is a blank line between outputs.

Sample Input

60
12
-1

Sample Output

Case 1.
2 2 3 1 5 1

Case 2.
2 2 3 1
<div style='font-family:Times New Roman;font-size:14px;background-color:F4FBFF;border:#B7CBFF 1px dashed;padding:6px'><div style='font-family:Arial;font-weight:bold;color:#7CA9ED;border-bottom:#B7CBFF 1px dashed'><i>Hint</i></div>
60=2^2*3^1*5^1
</div>

Author

lcy

Source

杭电ACM集训队训练赛(IV)



#include <iostream>
using namespace std;


int main()
{
 int n,p=1;
 while(cin >> n)
 {
  if(n<0) break;
  if(p!=1) cout<<endl;
  cout << "Case " << p << "."<<endl;
  p++;
  int m=0,i=2;
  while(i<=n)
  {
   if(n%i==0)
   {
    m++;
    n/=i;
   }
   else if(m!=0)
   {
    cout <<i<<" "<<m<<" ";
    m = 0;
    i++;
   }
   else
   {
    m=0;
    i++;
   }
  }
  if(m!=0)
  {
   cout <<i<<" "<<m<<" ";
  }
  cout<<endl;
 }
 return 0;
}

原文地址:https://www.cnblogs.com/lengxia/p/4387882.html