Number Sequence

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
1 1 3 1 2 10 0 0 0
 

Sample Output
2 5
 

Author
CHEN, Shunbao
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1008 1004 1021 1019 1002 









#include<iostream>
using namespace std;
int f[49];
int main()
{int i,j,k,l;
while(cin>>i>>j>>k&&i!=0)
{
f[1] = 1;
 f[2] = 1;
 for(l=3;l<49;l++)
 {f[l]=(i*f[l-1]+j*f[l-2])%7;}

 cout<<f[k%49]<<endl;


}



return 0;


}


原文地址:https://www.cnblogs.com/lengxia/p/4387871.html