九度 oj 题目1005:Graduate Admission

 双键值排序:先对副键值稳定排序,在对主键值排序。

题目描述:

    It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.
    Each applicant will have to provide two grades: the national entrance exam grade GE, and the interview grade GI. The final grade of an applicant is (GE + GI) / 2. The admission rules are:

    • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.
    • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade GE. If still tied, their ranks must be the same.
    • Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.
    • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

输入:

    Each input file may contain more than one test case.
    Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.
    In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.
    Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's GE and GI, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M-1, and the applicants are numbered from 0 to N-1.

输出:

    For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

样例输入:
11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4
样例输出:
0 10
3
5 6 7
2 8

1 4



#include <iostream>
using namespace std;
 
struct grade{
    int apNumber;
    int GE;
    float GFinal;
    int application[5];
};
grade GradeLine[105];
int Quotas[105];
int leftQuota[105];
int receiveQueue[100][40000];
int N,M;
int K; // 每个学生拥有的选项
 
bool win(grade a, grade b)
{
    if(a.GFinal>b.GFinal) return true;
    if(a.GFinal==b.GFinal && a.GE>=b.GE) return true;
    return false;
}
 
int main()
{
    while(cin>>N>>M>>K){
        grade *stu = new grade[N];
        for(int i=0;i<M;i++) {cin>>Quotas[i]; leftQuota[i]=Quotas[i];};
        int GI;
        for(int i=0;i<N;i++)
        {
            stu[i].apNumber=i;
            cin>>stu[i].GE>>GI;
            stu[i].GFinal = (stu[i].GE+GI)/2;
            for(int j=0;j<K;j++)
                cin>>stu[i].application[j];
        }
        // rank 全体 1.按副指标稳定排序 + 2.全体按主指标任意排序 完成
        for(int i=1;i<N;i++)
        {
            int j;
            grade tem=stu[i];
            for(j=i-1;j>=0&&stu[j].GE<tem.GE; stu[j+1]=stu[j--]);
            stu[j+1]=tem;
        }
        for(int i=1;i<N;i++)
        {
            int j;
            grade tem=stu[i];
            for(j=i-1;j>=0&&stu[j].GFinal<tem.GFinal; stu[j+1]=stu[j--]);
            stu[j+1]=tem;
        }
        // for(int i=0;i<N;i++) cout<<stu[i].GE<<" "<<stu[i].GFinal<<endl;
        // 判断录取
        for(int i=0;i<N;i++)
        {
            for(int j=0;j<K;j++)
            {
                int school_number = stu[i].application[j];
                if(leftQuota[school_number]>0)
                {
                       GradeLine[school_number] = stu[i];
                       int queIndex = Quotas[school_number]-leftQuota[school_number];
                       leftQuota[school_number]--;
                       receiveQueue[school_number][queIndex]=stu[i].apNumber;
                       break;
                }
                else if(win(stu[i], GradeLine[school_number]))
                 {
                       GradeLine[school_number] = stu[i];
                       int queIndex = Quotas[school_number]-leftQuota[school_number];
                       leftQuota[school_number]--;
                       receiveQueue[school_number][queIndex]=stu[i].apNumber;
                       break;
                 }
            }
        }
        // 打印结果:
        for(int i=0;i<M;i++)
        {
            int re_count = Quotas[i]-leftQuota[i];
            // 对每个学校录取同学的学号递增排序
            for(int st=1;st<re_count;st++)
            {
                int j;
                int tem=receiveQueue[i][st];
                for(j=st-1;j>=0&&receiveQueue[i][j]>tem; receiveQueue[i][j+1]=receiveQueue[i][j--]);
                receiveQueue[i][j+1]=tem;
            }
            for(int j=0;j<re_count-1;j++) cout<<receiveQueue[i][j]<<" ";
            if(re_count)cout<<receiveQueue[i][re_count-1]<<endl;
            else cout<<endl;
        }
    }
    return 0;
}
 
/**************************************************************
    Problem: 1005
    User: landflow
    Language: C++
    Result: Accepted
    Time:10 ms
    Memory:17148 kb
****************************************************************/

  

我的解法思路很简单,基本就是按着题目要求一步一步来的,中间用到了好几次排序,而且空间复杂度上也不小,

解法简单,如果再没有比较好的可读性就很悲哀了。 

原文地址:https://www.cnblogs.com/learn-to-rock/p/6389460.html