POJ 2230 Watchcow 欧拉图

Watchcow
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 8800   Accepted: 3832   Special Judge

Description

Bessie's been appointed the new watch-cow for the farm. Every night, it's her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she's done. 

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she's seen everything she needs to see. But since she isn't, she wants to make sure she walks down each trail exactly twice. It's also important that her two trips along each trail be in opposite directions, so that she doesn't miss the same thing twice. 

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.

Input

* Line 1: Two integers, N and M. 

* Lines 2..M+1: Two integers denoting a pair of fields connected by a path.

Output

* Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.

Sample Input

4 5
1 2
1 4
2 3
2 4
3 4

Sample Output

1
2
3
4
2
1
4
3
2
4
1

Hint

OUTPUT DETAILS: 

Bessie starts at 1 (barn), goes to 2, then 3, etc...

Source

 
把无向图变成有向图,正反两边存入边的集合,接下来深搜一遍
 
#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
#include<string>
#include<cmath>
#include<map>
#define debug(a) cout << #a << " " << a << endl
using namespace std;
typedef long long ll;
const int MAXN = 100010; //数组得开到两倍,因为这里做处理变成有向图扩大了两倍
struct node {
    int to, next;
};
node edge[MAXN];
int head[MAXN], vis[MAXN], n, m, ans;
void dfs( int x ) {
    for( int i = head[x]; i != -1; i = edge[i].next ) {
        if( !vis[i] ) {
            vis[i] = 1;
            dfs(edge[i].to);
        }
    }
    cout << x << endl;
}
int main() {
    while( cin >> n >> m ) {
        for( int i = 0; i < MAXN; i ++ ) {
            head[i] = -1;
        }
        ans = 0;
        memset( vis, 0, sizeof(vis) );
        while( m -- ) {
            int x, y;
            cin >> x >> y;
            edge[ans].to = y;
            edge[ans].next = head[x];
            head[x] = ans;
            ans ++;
            edge[ans].to = x;
            edge[ans].next = head[y];
            head[y] = ans;
            ans ++;
        }
        dfs(1);
    }
    return 0;
}
 
 
彼时当年少,莫负好时光。
原文地址:https://www.cnblogs.com/l609929321/p/9004715.html