快速幂 HDU 1061 Rightmost Digit *

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 57430    Accepted Submission(s): 21736


Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 
Output
For each test case, you should output the rightmost digit of N^N.
 
Sample Input
2
3
4
 
Sample Output
7
6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 
Author
Ignatius.L

快速幂的运用,每次相乘时余十就行

注意碰到次方很多的时候可以考虑使用快速幂了

这里贴一份讲快速幂的博客  http://blog.csdn.net/hikean/article/details/9749391

#include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#define ll long long
#define mod 1000000007
using namespace std;
int main()
{
    int T;
    cin >> T;
    while(T--){
        int n;
        cin >> n;
        int ans = 1,mul = n,num = n;
        mul = mul % 10;
        while(num){
            if(num%2==1){
                ans = (ans*mul)%10;
            }
            mul = (mul*mul)%10;
            num /= 2;
        }
        cout << ans%10 << endl;
    }
    return 0;
}
彼时当年少,莫负好时光。
原文地址:https://www.cnblogs.com/l609929321/p/7272847.html