POJ 3268 Silver Cow Party 单向最短路

Silver Cow Party
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 22864   Accepted: 10449

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: NM, and X 
Lines 2..M+1: Line i+1 describes road i with three space-separated integers: AiBi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

Source

求两次最短路,第一次求t到其余各点的最短路,第二次求各点到t的最短路。
最后求的是所有点到t的距离的最大值
#include <iostream>
#include <deque>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue> 
#include <algorithm>
#define maxn 100010
using namespace std;
vector<pair<int,int> > E[maxn];
int d1[maxn],d2[maxn];
int n,m,t,x[maxn],y[maxn],z[maxn];
int max(int a,int b){
    if(a>=b){
        return a;
    }
    return b;
}
void init1(){
    for(int i=0;i<maxn;i++){
        E[i].clear();
        d1[i] = 1e9;
    }
}
void init2(){
    for(int i=0;i<maxn;i++){
        E[i].clear();
        d2[i] = 1e9;
    }
}
void dijkstra(int t,int d[]){
    d[t] = 0;
    priority_queue<pair<int,int> > q;
    q.push(make_pair(-d[t],t));
    while(!q.empty()){
        int now = q.top().second;
        q.pop();
        for(int i=0;i<E[now].size();i++){
            int v = E[now][i].first;
            if(d[v] > d[now] + E[now][i].second){
                d[v] = d[now] + E[now][i].second;
                q.push(make_pair(-d[v],v));
            }
        }
    }
}
int main()
{
    while(cin >> n >> m >> t){
        init1();
        for(int i=0;i<m;i++){
            cin >> x[i] >> y[i] >> z[i];
            E[x[i]].push_back(make_pair(y[i],z[i]));
        }
        dijkstra(t,d1);//正求一次    
        init2();
        for(int i=0;i<m;i++){
            E[y[i]].push_back(make_pair(x[i],z[i]));
        }    //记得在这里要把所有的路反过来
        dijkstra(t,d2);//反求一次    
        int num = -1;
        for(int i=1;i<=n;i++){
            num = max(num,d1[i]+d2[i]);
        }
        cout << num << endl;
    }
    return 0;
}
彼时当年少,莫负好时光。
原文地址:https://www.cnblogs.com/l609929321/p/7240806.html