java hdu A+B for Input-Output Practice (IV)

A+B for Input-Output Practice (IV)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 105601    Accepted Submission(s): 55782


Problem Description
Your task is to Calculate the sum of some integers.
 
Input
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
 
Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 
 
Sample Input
4 1 2 3 4 5 1 2 3 4 5 0
 
Sample Output
10 15
 
Author
lcy
 
Recommend
JGShining   |   We have carefully selected several similar problems for you:  1093 1094 1095 1096 1000 
怎么处理大数累加问题
import java.math.BigInteger;
import java.util.Scanner;
public class Main
{
    public static void main(String[] args)
    { 
        BigInteger a,b,d;
        String c = "0";
        d = new BigInteger(c);
        Scanner in = new Scanner(System.in);
        while(in.hasNextInt())
        {
            b = d;
            int t = in.nextInt();
            if(t == 0)
                break;
            for(int i=1;i<=t;i++)
            {
                a = in.nextBigInteger();
                b = a.add(b);//注意使用add方法时有返回值!!!
            }
            System.out.println(b);
        }
    }
}
彼时当年少,莫负好时光。
原文地址:https://www.cnblogs.com/l609929321/p/7043833.html