Least Common Multiple

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 
Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1
 
Sample Output
105

10296


两个数的最小公倍数=两个数的乘积除以最大公约数。

最大公约数用欧几里得算法求出。

#include<iostream>
using namespace std;
int gcd(int a,int b)
{
if(b==0)
        return a;
else
return gcd(b,a%b);
}
int main()
{
int n,m,ans,x;
cin>>n;
while(n--)
{
cin>>m>>ans;//ans为第一个数字
for(int i=1;i<m;i++)//从第二个数字开始输入
{
cin>>x;
ans=ans*x/gcd(ans,x);//这里要先算除法后算乘法
}
cout<<ans<<endl;
}
return 0;
}

原文地址:https://www.cnblogs.com/kuroko-ghh/p/9363357.html