HDU1.31-Design T-Shirt

Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible to have everybody perfectly satisfied. So he took a poll to collect people's opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each element a number of satisfaction. However, XKA can only put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized.
 

Input
The input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number of elements XKA will put into his design. Then N lines follow, each contains M numbers. The j-th number in the i-th line represents the i-th person's satisfaction on the j-th element.
 

Output
For each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions, you must output the one with minimal indices. The indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line.
 

Sample Input
3 6 4
2 2.5 5 1 3 4
5 1 3.5 2 2 2
1 1 1 1 1 10
3 3 2
1 2 3
2 3 1
3 1 2
 

Sample Output
6 5 3 1
2 1
/*题目大意就是比较输入的N行M列数据,M列数据分别求和取前K个最大的,然后输出行的编号(从大到小)提交时一定要选择c++而不是g++否则会显示超时*/
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
float sum[1000000];
float ele[1000][1000];
int output[1000],t;
int main(int argc, char const *argv[])
{
int N,M,K;
while(cin>>N>>M>>K)
{   t=0;
       for(int i=0;i<N;i++)
        for(int j=0;j<M;j++)
        cin>>ele[i][j];
        memset(sum,0,sizeof(sum));
        for(int j=0;j<M;j++)
        for(int i=0;i<N;i++)
        sum[j]+=ele[i][j];//按列求和
        for(int i=0;i<K;i++)
          {   int temp=0;
          for(int j=0;j<M;j++)
          {
          if(sum[j]>sum[temp])
          {
          temp=j;
          }
          }
          output[t++]=temp+1;
          sum[temp]=0;//每次将上次的最大的那个数字清为0,保证得到的为次大的和       
          }
         sort(output,output+K);
          for(int i=K-1;i>0;i--)
          cout<<output[i]<<" ";
          cout<<output[0]<<endl;
}
return 0;
}
原文地址:https://www.cnblogs.com/kuroko-ghh/p/9363356.html