UVa 10391 Compound Words

Problem E: Compound Words

You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.

Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 120,000 words.

Output

Your output should contain all the compound words, one per line, in alphabetical order.

Sample Input

a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra

Sample Output

alien
newborn


这道题刚开始直接暴力,遍历每个单词并且合成,然后寻找是否有合成后的单词出现,结果TLE
后来把每个单词拆分,然后看拆分后的两个部分是否存在,AC
思路很重要,盲目暴力准TLE!

#include <bits/stdc++.h>
using namespace std;

int main()
{
    vector<string> table;
    string temp;
    while(cin >> temp)
        table.push_back(temp);
    sort(table.begin(), table.end());

    for(int i = 0; i<table.size(); i++)
    {
        for(int j = 1; j<table[i].size()-1; j++)
        {
            string str1 = table[i].substr(0, j);
            string str2 = table[i].substr(j, table[i].size());
            if(binary_search(table.begin(), table.end(), str1) && binary_search(table.begin(), table.end(), str2))
            {
                cout << table[i] << endl;
                break;
            }
        }
    }
    return 0;
}


原文地址:https://www.cnblogs.com/kunsoft/p/5312795.html