ZOJ 3204 Connect them (最小生成树,输出字典序最小的解)

Connect them

Time Limit: 1 Second      Memory Limit: 32768 KB

You have n computers numbered from 1 to n and you want to connect them to make a small local area network (LAN). All connections are two-way (that is connecting computers i and j is the same as connecting computers j and i). The cost of connecting computer i and computer j is cij. You cannot connect some pairs of computers due to some particular reasons. You want to connect them so that every computer connects to any other one directly or indirectly and you also want to pay as little as possible.

Given n and each cij, find the cheapest way to connect computers.

Input

There are multiple test cases. The first line of input contains an integer T (T <= 100), indicating the number of test cases. Then T test cases follow.

The first line of each test case contains an integer n (1 < n <= 100). Then n lines follow, each of which contains n integers separated by a space. The j-th integer of the i-th line in these n lines is cij, indicating the cost of connecting computers i and j (cij = 0 means that you cannot connect them). 0 <= cij <= 60000, cij = cji, cii = 0, 1 <= i, j <= n.

Output

For each test case, if you can connect the computers together, output the method in in the following fomat:

i1 j1 i1 j1 ......

where ik ik (k >= 1) are the identification numbers of the two computers to be connected. All the integers must be separated by a space and there must be no extra space at the end of the line. If there are multiple solutions, output the lexicographically smallest one (see hints for the definition of "lexicography small") If you cannot connect them, just output "-1" in the line.

Sample Input

2
3
0 2 3
2 0 5
3 5 0
2
0 0
0 0

Sample Output

1 2 1 3
-1

Hints:
A solution A is a line of p integers: a1, a2, ...ap.
Another solution B different from A is a line of q integers: b1, b2, ...bq.
A is lexicographically smaller than B if and only if:
(1) there exists a positive integer r (r <= p, r <= q) such that ai = bi for all 0 < i < r and ar < br
OR
(2) p < q and ai = bi for all 0 < i <= p


Author: CAO, Peng
Source: The 6th Zhejiang Provincial Collegiate Programming Contest

最小生成树,要求最小字典序的解。

用kruscal算法,先排序,输出的时候也要排序。

/*
ZOJ 3204
求字典序最小的最小生成数
*/
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;

const int MAXN=110;

int F[MAXN];
struct Edge
{
    int from,to;
    int w;
}edge[MAXN*MAXN];
int tol;
Edge ans[MAXN*MAXN];
int cnt;
void addedge(int u,int v,int w)
{
    edge[tol].from=u;
    edge[tol].to=v;
    edge[tol].w=w;
    tol++;
}
bool cmp1(Edge a,Edge b)
{
    if(a.w!=b.w)return a.w<b.w;
    else if(a.from!=b.from)return a.from<b.from;
    else return a.to<b.to;
}
bool cmp2(Edge a,Edge b)
{
    if(a.from!=b.from)return a.from<b.from;
    else return a.to<b.to;
}
int find(int x)
{
    if(F[x]==-1)return x;
    return F[x]=find(F[x]);
}
void kruscal()
{
    memset(F,-1,sizeof(F));
    cnt=0;//加入最小生成树的边
    for(int k=0;k<tol;k++)
    {
        int u=edge[k].from;
        int v=edge[k].to;
        int t1=find(u);
        int t2=find(v);
        if(t1!=t2)
        {
            ans[cnt++]=edge[k];
            F[t1]=t2;
        }
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    int n;
    while(T--)
    {
        scanf("%d",&n);
        tol=0;
        int w;
        for(int i=1;i<=n;i++)
          for(int j=1;j<=n;j++)
          {
              scanf("%d",&w);
              if(j<=i)continue;
              if(w==0)continue;
              addedge(i,j,w);
          }
        sort(edge,edge+tol,cmp1);
        kruscal();
        if(cnt!=n-1)
        {
            printf("-1\n");
            continue;
        }
        else
        {
            sort(ans,ans+cnt,cmp2);
            for(int i=0;i<cnt-1;i++)
              printf("%d %d ",ans[i].from,ans[i].to);
            printf("%d %d\n",ans[cnt-1].from,ans[cnt-1].to);
        }
    }
    return 0;
}
原文地址:https://www.cnblogs.com/kuangbin/p/2705883.html