HDU 1229 还是A+B(水题)

还是A+B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9799    Accepted Submission(s): 4814


Problem Description
读入两个小于10000的正整数A和B,计算A+B。需要注意的是:如果A和B的末尾K(不超过8)位数字相同,请直接输出-1。
 
Input
测试输入包含若干测试用例,每个测试用例占一行,格式为"A B K",相邻两数字有一个空格间隔。当A和B同时为0时输入结束,相应的结果不要输出。
 
Output
对每个测试用例输出1行,即A+B的值或者是-1。
 
Sample Input
1 2 1 11 21 1 108 8 2 36 64 3 0 0 1
 
Sample Output
3 -1 -1 100
 
Source
 
Recommend
JGShining
 
 
 
临睡前无耻地刷了两道水题,罪过啊!!!!
#include<stdio.h>
int main()
{
int a,b,k;
while(scanf("%d%d%d",&a,&b,&k))
{
if(a==0&&b==0) break;
int tt=1;
while(k--)
{
tt*=10;
}
if(a%tt==b%tt)
{
printf("-1\n");
}
else printf("%d\n",a+b);
}
return 0;
}
原文地址:https://www.cnblogs.com/kuangbin/p/2397233.html