ACM HDU 1194 Beat the Spread!(简单的水题)

Beat the Spread!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1723    Accepted Submission(s): 899


Problem Description
Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the absolute difference between the two scores.

Given the winning numbers for each type of bet, can you deduce the final scores?
 

Input
The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores.
 

Output
For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing "impossible". Recall that football scores are always non-negative integers.
 

Sample Input
2 40 20 20 40
 

Sample Output
30 10 impossible
 

Source
 

Recommend
Ignatius.L
很简单的水题,看清楚题目,注意细节,细节决定成败!
 
#include<stdio.h>
int main()
{
int T,A,B;
int a,b;
scanf(
"%d",&T);
while(T--)
{
scanf(
"%d%d",&A,&B);
if(A<B) printf("impossible\n");
else if((A+B)%2!=0) printf("impossible\n");//这个需要判断下,因为这个WA了一次
else
{
a
=(A+B)/2;
b
=(A-B)/2;
if(a<b){int c=a;a=b;b=c;}
printf(
"%d %d\n",a,b);
}
}
return 0;
}

原文地址:https://www.cnblogs.com/kuangbin/p/2124257.html