ACM HDU 1020Encoding

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11132    Accepted Submission(s): 4673


Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.
 

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
 

Output
For each test case, output the encoded string in a line.
 

Sample Input
2 ABC ABBCCC
 

Sample Output
ABC A2B3C
 

Author
ZHANG Zheng
 

Recommend
JGShining
 
 
#include<stdio.h>
const int MAXN=10005;
char a[MAXN];
int main()
{
    int i,t;
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s",&a);
        i=0;
        while(a[i]!='\0')
        {
            t=i;
            while(a[t+1]==a[i])
            {
                t++;
            }    
            if(t>i)printf("%d",t-i+1);
            printf("%c",a[i]);
            i=t;
            i++;
        } 
        printf("\n");   
    } 
    return 0;   
}    

原文地址:https://www.cnblogs.com/kuangbin/p/2120521.html