poj3667 Hotel (线段树 区间合并 求一块满足条件的最左边的空白空间 )

poj3667 Hotel
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 18925 Accepted: 8242
Description

The cows are journeying north to Thunder Bay in Canada to gain cultural enrichment and enjoy a vacation on the sunny shores of Lake Superior. Bessie, ever the competent travel agent, has named the Bullmoose Hotel on famed Cumberland Street as their vacation residence. This immense hotel has N (1 ≤ N ≤ 50,000) rooms all located on the same side of an extremely long hallway (all the better to see the lake, of course).

The cows and other visitors arrive in groups of size Di (1 ≤ Di ≤ N) and approach the front desk to check in. Each group i requests a set of Di contiguous rooms from Canmuu, the moose staffing the counter. He assigns them some set of consecutive room numbers r..r+Di-1 if they are available or, if no contiguous set of rooms is available, politely suggests alternate lodging. Canmuu always chooses the value of r to be the smallest possible.

Visitors also depart the hotel from groups of contiguous rooms. Checkout i has the parameters Xi and Di which specify the vacating of rooms Xi ..Xi +Di-1 (1 ≤ Xi ≤ N-Di+1). Some (or all) of those rooms might be empty before the checkout.

Your job is to assist Canmuu by processing M (1 ≤ M < 50,000) checkin/checkout requests. The hotel is initially unoccupied.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Line i+1 contains request expressed as one of two possible formats: (a) Two space separated integers representing a check-in request: 1 and Di (b) Three space-separated integers representing a check-out: 2, Xi, and Di

Output

* Lines 1.....: For each check-in request, output a single line with a single integer r, the first room in the contiguous sequence of rooms to be occupied. If the request cannot be satisfied, output 0.

Sample Input

10 6
1 3
1 3
1 3
1 3
2 5 5
1 6
Sample Output

1
4
7
0
5

思路:
线段树区间合并,算是模板题了把。。
乍一看好像很复杂,其实理清楚思路的话还是不算难的
这道题讲解起来太麻烦了,就不写思路了。给一篇我觉得讲解的很好的博客:https://www.cnblogs.com/scau20110726/archive/2013/05/07/3065418.html

实现代码:

#include<iostream>
using namespace std;
#define ll long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define mid int m = (l + r) >> 1
const int M = 5e5+10;
int cov[M<<2],lsum[M<<2],rsum[M<<2],sum[M<<2];
void pushdown(int m,int rt){
    if(cov[rt]!=-1){
        cov[rt<<1] = cov[rt<<1|1] = cov[rt];
        sum[rt<<1] = lsum[rt<<1] = rsum[rt<<1] = cov[rt]?0:m-(m>>1);
        sum[rt<<1|1] = lsum[rt<<1|1] = rsum[rt<<1|1] = cov[rt]?0:(m>>1);
        cov[rt] = -1;
    }
}

void pushup(int m,int rt){
    lsum[rt] = lsum[rt<<1];
    rsum[rt] = rsum[rt<<1|1];
    if(lsum[rt] == m-(m>>1)) lsum[rt] += lsum[rt<<1|1];
    if(rsum[rt] == (m>>1)) rsum[rt] += rsum[rt<<1];
    sum[rt] = max(lsum[rt<<1|1]+rsum[rt<<1],max(sum[rt<<1],sum[rt<<1|1]));
}

void build(int l,int r,int rt){
    sum[rt] = lsum[rt] = rsum[rt] = r - l + 1;
    cov[rt] = -1;
    if(l == r) return ;
    int m = (l + r) >> 1;
    build(lson); build(rson);
}

void update(int L,int R,int c,int l,int r,int rt){
    if(L <= l&&R >= r){
        sum[rt] = lsum[rt] = rsum[rt] = c?0:r-l+1;
        cov[rt] = c;
        return ;
    }
    pushdown(r - l + 1,rt);
    int m = (l + r) >> 1;
    if(L <= m) update(L,R,c,lson);
    if(R > m) update(L,R,c,rson);
    pushup(r - l + 1,rt);
}

int query(int w,int l,int r,int rt){
    if(l == r) return l;
    pushdown(r - l + 1,rt);
    int m = (l + r) >> 1;
    if(sum[rt<<1] >= w) return query(w,lson);
    else if(lsum[rt<<1|1] + rsum[rt<<1] >= w) return m - rsum[rt<<1] + 1;
    else return query(w,rson);
}

int main()
{
    int n,m,x,a,b,y;
    cin>>n>>m;
    build(1,n,1);
    while(m--){
        cin>>x;
        if(x == 1){
            cin>>y;
            if(sum[1] < y) cout<<0<<endl;
            else {
            int p = query(y,1,n,1);
            cout<<p<<endl;
            update(p,p+y-1,1,1,n,1);
            }
        }
        else{
            cin>>a>>b;
            update(a,a+b-1,0,1,n,1);
        }
    }
}
原文地址:https://www.cnblogs.com/kls123/p/8604876.html