HDU 1698 Just a Hook (线段树区间更新入门题)

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 36705    Accepted Submission(s): 17920


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 
Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 
Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 
Sample Input
1 10 2 1 5 2 5 9 3
 
Sample Output
Case 1: The total value of the hook is 24.
 
实现代码:
#include<iostream>
#include<algorithm>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
const int M = 200000;
int sum[M<<2],lazy[M<<2];
void pushup(int rt){
    sum[rt] = sum[rt<<1] + sum[rt<<1|1];
}

void pushdown(int rt,int m){
    if(lazy[rt]){
        lazy[rt<<1] = lazy[rt<<1|1] = lazy[rt];
        sum[rt<<1] = (m-(m>>1))*lazy[rt];
        sum[rt<<1|1] = (m>>1)*lazy[rt];
        lazy[rt] = 0;
    }
}

void build(int l,int r,int rt){
    lazy[rt] = 0;
    sum[rt] = 1;
    if(l == r) return ;
    int m = (l + r) >>1;
    build(lson);
    build(rson);
    pushup(rt);
}
void update(int L,int R,int c,int l,int r,int rt){
     if(L<=l&&R>=r){
        lazy[rt] = c;
        sum[rt] = c * (r - l + 1);
        return ;
     }
     pushdown(rt,r - l + 1);
     int m = (l + r)>>1;
     if(L <= m) update(L,R,c,lson);
     if(R > m) update(L,R,c,rson);
     pushup(rt);
}

int query(int L,int R,int l,int r,int rt){
    if(L<=l&&R>=r){
        return sum[rt];
    }
    pushdown(rt,r - l + 1);
    int m = (l + r)>>1;
    int ret = 0;
    if(L <= m) ret += query(L,R,lson);
    if(R > m) ret += query(L,R,rson);
    return ret;
}
int main(){
    ios::sync_with_stdio(false);
    cin.tie(0);
    int t,n,q,l,r,c;
    while(cin>>t){
       for(int i = 1;i <= t; i ++){
            cin>>n;
            build(1,n,1);
            cin>>q;
            while(q--){
            cin>>l>>r>>c;
            update(l,r,c,1,n,1);
            }
            cout<<"Case "<<i<<": The total value of the hook is ";
            cout<<query(1,n,1,n,1)<<"."<<endl;
        }
    }
}
原文地址:https://www.cnblogs.com/kls123/p/8075594.html