HDU 1069 Monkey and Banana

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food. 

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks. 

InputThe input file will contain one or more test cases. The first line of each test case contains an integer n, 
representing the number of different blocks in the following data set. The maximum value for n is 30. 
Each of the next n lines contains three integers representing the values xi, yi and zi. 
Input is terminated by a value of zero (0) for n. 
OutputFor each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height". 
Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

解题思路:
就是求一个序列的和,不过由于长宽高不确定,则直接分别讨论三个数字为高的情况,并对其长进行排序,这样可以节省步数
那么现在这个问题就可以转换成类似求最大递增子序列问题一样思路的DP,然后就很好写了

实现代码:
#include<bits/stdc++.h>
using namespace std;

struct abc
{
    int a,b,c;
}mmp[1000];

bool cmp(abc a,abc b)
{
    if(a.a==b.a)
        return a.b>b.b;
    else
        return a.a>b.a;
}

void fuck(int a[])
{
    int t;
    for(int i = 0; i < 3; i ++)
       for(int j = i;j < 3; j ++)
        if(a[j]>a[i])
       {
           t = a[j];
           a[j] = a[i];
           a[i] = t ;
       }
}

int main()
{
    int m,n,i,j,a[35],maxsum[1000],maxx;
    int num = 0;
    while(cin>>m&&m)
    {
        memset(maxsum,0,sizeof(maxsum));
        int n = 0;
        for(i = 0;i < m;i ++)
        {
            cin>>a[0]>>a[1]>>a[2];
            fuck(a);
            mmp[n].a = a[0];
            mmp[n].b = a[1];
            mmp[n].c = a[2];
            n++;
            mmp[n].a = a[0];
            mmp[n].b = a[2];
            mmp[n].c = a[1];
            n++;
            mmp[n].a = a[1];
            mmp[n].b = a[2];
            mmp[n].c = a[0];
            n++;
        }
        sort(mmp,mmp+n,cmp);
        for(i = 0;i < n;i++)
            maxsum[i] = mmp[i].c;
        for(i = 0;i < n;i++)
        {
            //cout<<maxsum[i]<<endl;
            maxx = 0;
            for(j = 0;j < i;j++)
            {
                if(mmp[j].a>mmp[i].a&&mmp[j].b>mmp[i].b&&maxsum[j]>maxx)
                    maxx = maxsum[j];
            }
            maxsum[i]+=maxx;
        }
        maxx = maxsum[0];
        for(i = 1;i< n;i++)
            if(maxsum[i]>maxx)
                maxx = maxsum[i];
        num++;
        cout<<"Case "<<num<<": maximum height = "<<maxx<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/kls123/p/6837491.html