poj 2386 Lake Counting(dfs)

Lake Counting
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 28220   Accepted: 14160

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

Java AC 代码

import java.util.Scanner;

public class Main {
    
    static String field[][];
    
    static int rows;
    static int columns;
    
    static int ponds;
    
    static boolean marked[][];
    
    static int dx[] = {-1, 0, 1, -1, 1, -1, 0, 1};
    static int dy[] = {1, 1, 1, 0, 0, -1, -1, -1};
    
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        rows = sc.nextInt();
        columns = sc.nextInt();
        field = new String[rows][columns];
        marked = new boolean[rows][columns];
        for(int i = 0; i < rows; i++) {
            String line = sc.next();
            for(int j = 0; j < columns; j++) {
                field[i][j] = line.substring(j, j + 1);
            }
        }
        
        for(int i = 0; i < rows; i++)
            for(int j = 0; j < columns; j++) {
                if(!marked[i][j] && field[i][j].equals("W")) {
                    dfs(i, j);
                    ponds++;
                }
            }
        System.out.println(ponds);
            
    }
    
    public static void dfs(int row, int col) {
        
        for(int i = 0; i < 8; i++) {
            int _row = row + dy[i];
            int _col = col + dx[i];
            if(_row < rows && _row >= 0 && _col < columns && _col >= 0 && !marked[_row][_col] && field[_row][_col].equals("W")) {
                marked[_row][_col] = true;
                dfs(_row, _col);
            }
        }
    }
}
原文地址:https://www.cnblogs.com/kkkkkk/p/5539882.html