Wormholes

Wormholes
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 16897   Accepted: 5959

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

#include <iostream>
#include <fstream>
#include <vector>
#include <string>
#include <algorithm>
#include <map>
#include <stack>
#include <cmath>
#include <queue>
#include <set>


using namespace std;

const int INF = 1<<30 - 1;

int Dist[501];



struct Edge
{
int start;
int end;
int length;
};

vector<Edge> Edges;

int main()
{



int F;

cin >> F;

while( F-- )
{
int N,M,W;

cin >> N >> M >> W;

//clear
for( int i = 0 ; i < N ; ++i )
{
Dist[i] = INF;
}
Edges.clear();

for( int i = 0 ; i < M ; ++i )
{
int S , E , T;

cin >> S >> E >> T;

Edge edge1;
edge1.start = S;
edge1.end = E;
edge1.length = T;
Edges.push_back(edge1);
Edge edge2;
edge2.start = E;
edge2.end = S;
edge2.length = T;
Edges.push_back(edge2);
}

for( int i = 0 ; i < W ; ++i )
{
int S , E , T;

cin >> S >> E >> T;

Edge edge;
edge.start = S;
edge.end = E;
edge.length = -T;
Edges.push_back(edge);
}

//bellman
Dist[0] = 0;
for( int it = 0 ; it < N -1 ; ++it )
{
for( int i = 0; i < Edges.size() ; ++i )
{
if ( Dist[Edges[i].start] + Edges[i].length < Dist[Edges[i].end] )
{
Dist[Edges[i].end] = Dist[Edges[i].start] + Edges[i].length;
}
}
}

for( int i = 0; i < Edges.size() ; ++i )
{
if ( Dist[Edges[i].start] + Edges[i].length < Dist[Edges[i].end] )
{
goto YES;
}
}

printf("NO\n");
continue;

YES:
printf("YES\n");
continue;
}



return 0;
}
原文地址:https://www.cnblogs.com/kking/p/2333853.html