poj1068

Parencodings
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 24641   Accepted: 14491

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source

个人感觉编程能力实在是弱。一题简单模拟都卡了好久,还要抄网上的程序。

题意如下,给定一个完整的括号序列(每个左括号都有一个右括号和它对应),输入n行,输入这个序列第i个右括号前总共有几个左括号,求每个对应左右括号里面的左右括号数(包括它本身)。

思路如下:既然输入的是每个右括号之前所有的左括号数,那么久每读入一个数据,记录下A(i)-A(i-1)个左括号,再记录一个右括号。输出时,用递归法,若该括号是左括号,证明其可以再次向右递归,沿途向右递归记录下内部的括号总数,知道遇到了它的“另一半”,则结束递归,记录当前值。

15773121

  ksq2013 1068 Accepted 696K 0MS G++ 871B 2016-07-21 13:18:24
#include<vector>
#include<cstdio>
#include<iostream>
using namespace std;
int n,cnt,w[10000];
vector<bool>bin;
void in()
{
    pair<int,int>p;
    p.first=p.second=0;
    for(int i=0;i<n;i++){
        scanf("%d",&p.second);
        for(int j=1;j<=p.second-p.first;j++)bin.push_back(1);
        bin.push_back(0);
        p.first=p.second;
    }
}
int solve(int &l)
{
    int res=1;
    for(;;){
        if(bin[l]){
            l++;
            res+=solve(l);
        }
        else{
            l++;
            w[cnt++]=res;
            return res;
        }
    }
}
void out()
{
    printf("%d",w[0]);
    for(int i=1;i<n;i++)
        printf(" %d",w[i]);
    putchar('
');
}
int main()
{
    int T,l;
    scanf("%d",&T);
    for(;T;T--){
        l=cnt=0;
        bin.clear();
        scanf("%d",&n);
        in();
        solve(l);
        out();
    }
    return 0;
}



原文地址:https://www.cnblogs.com/keshuqi/p/5957739.html