洛谷 P2911 [USACO08OCT]牛骨头Bovine Bones

题目描述

Bessie loves board games and role-playing games so she persuaded Farmer John to drive her to the hobby shop where she purchased three dice for rolling. These fair dice have S1, S2, and S3 sides

respectively (2 <= S1 <= 20; 2 <= S2 <= 20; 2 <= S3 <= 40).

Bessie rolls and rolls and rolls trying to figure out which three-dice sum appears most often.

Given the number of sides on each of the three dice, determine which three-dice sum appears most frequently. If more than one sum can appear most frequently, report the smallest such sum.

POINTS: 70

贝茜喜欢玩棋盘游戏和角色扮演游戏,所以她说服了约翰开车带她去小商店.在那里她买了 三个骰子.这三个不同的骰子分别有s1 s2 s3为个面.

贝茜扔埃扔埃扔埃对于一个有S个面的骰子,每个面上的数字是1,2,3,...,S.每个面出现的概率 均等.她希望找出在所有三个面上的数字的和中,哪个出现的概率最大.

现在给出每个骰子的面数,需要求出哪个所有三个面上的数字的和出现得最频繁.如果有很 多个和出现的概率相同,那么只需要输出最小的那个.

输入输出格式

输入格式:

  • Line 1: Three space-separated integers: S1, S2, and S3

输出格式:

  • Line 1: The smallest integer sum that appears most frequently when the dice are rolled in every possible combination.

输入输出样例

输入样例#1

3 2 3

输出样例#1

5

说明

Here are all the possible outcomes.

1 1 1 -> 3 1 2 1 -> 4 2 1 1 -> 4 2 2 1 -> 5 3 1 1 -> 5 3 2 1 -> 6 1 1 2 -> 4 1 2 2 -> 5 2 1 2 -> 5 2 2 2 -> 6 3 1 2 -> 6 3 2 2 -> 7 1 1 3 -> 5 1 2 3 -> 6 2 1 3 -> 6 2 2 3 -> 7 3 1 3 -> 7 3 2 3 -> 8

Both 5 and 6 appear most frequently (five times each), so 5 is the answer.

/*
枚举所有可能出现的数统计出现的次数。
*/
#include<cstdio>
using namespace std;
int f[1001],ans,max,s1,s2,s3;
int main()
{
    int i,j,k;
    scanf("%d%d%d",&s1,&s2,&s3);
    for(i=1;i<=s3;i++)
      for(j=1;j<=s2;j++)
        for(k=1;k<=s1;k++)
          f[i+j+k]++;
    for(i=1;i<=s1+s2+s3;i++)
      if(max<f[i])
      {
          ans=i;
          max=f[i];
      }
    printf("%d",ans);
    return 0;
}
原文地址:https://www.cnblogs.com/jyhywh/p/6754299.html