Elevator 分类: HDU 2015-06-19 21:52 13人阅读 评论(0) 收藏

Elevator
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 51396 Accepted Submission(s): 28377

Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output
Print the total time on a single line for each test case.

Sample Input

1 2 3 2 3 1 0

Sample Output

17 41

#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
    int a,n,sum,ans;
    while(cin>>n,n)
    {
        sum=0;
        ans=0;
        for(int i=0;i<n;i++)
        {
            cin>>a;
            if(a>ans)
            {
                sum+=((a-ans)*6+5);
            }
            else
            {
                sum+=((ans-a)*4+5);
            }
            ans=a;
        }
        cout<<sum<<endl;
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

原文地址:https://www.cnblogs.com/juechen/p/4722007.html