最小生成树 D

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. 

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179
#include<iostream>
#include<string>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<iomanip>
using namespace std;
#define MAXN 104
#define INF 0x3f3f3f3f
bool been[MAXN];
int n,q,g[MAXN][MAXN],lowcost[MAXN];
/*
最小生成树,如果D(a,b)<=ra+rb,那么g[a][b]=0
否则D(a,b)>ra+rb,g[a][b] = ra+rb-D(a,b)
*/
int Prim(int beg)
{
    int ans = 0;
    memset(been,false,sizeof(been));
    for(int i=1;i<=n;i++)
    {
        if(i==beg) lowcost[i] = 0;
        else lowcost[i] = g[beg][i];
    }
    been[beg] = true;
    for(int j=1;j<n;j++)
    {
        int Minc = INF,k=-1;
        for(int i=1;i<=n;i++)
        {
            if(!been[i]&&lowcost[i]<Minc)
            {
                Minc = lowcost[i];
                k = i;
            }
        }
        if(k==-1) return -1;
        been[k] = true;
        ans+=Minc;
        for(int i=1;i<=n;i++)
        {
            if(!been[i]&&lowcost[i]>g[k][i])
                lowcost[i] = g[k][i];
        }
    }
    return ans;
}
int main()
{
    cin>>n;
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            cin>>g[i][j];
        }
    }
    cin>>q;
    int tx,ty;
    for(int i=1;i<=q;i++)
    {
        cin>>tx>>ty;
        g[tx][ty] = g[ty][tx] = 0;
    }
    int ans = Prim(1);
    cout<<ans<<endl;
    return 0;
}
原文地址:https://www.cnblogs.com/joeylee97/p/6589896.html