Phone List(The 2007 Nordic Collegiate Programming Contest)

Phone List

Time Limit: 2 Sec  Memory Limit: 64 MB
Submit: 774  Solved: 149
[Submit][Status][Discuss]

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

- Emergency 911
- Alice 97 625 999
- Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000.Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

HINT

zoj2876

Source

The 2007 Nordic Collegiate Programming Contest


代码

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
bool cmp( const void *a , const void *b)
{
   return strcmp((char *)a,(char *)b);//(这里按字典序排序
}
int main()
{
    int w,l;
    scanf("%d",&w);
    for(l=1;l<=w;l++)
    {
        char s[10000][11];
        int i,n,j,k,len,g=0;
        scanf("%d",&n);
        getchar();
        for(i=0;i<=n-1;i++)
            gets(s[i]);
        qsort(s,n,sizeof(s[0]),cmp);
        for(i=0;i<n;i++)
        {
            len=strlen(s[i]);
            {
                for(k=0;k<len;k++)
                    if(s[i][k]!=s[i+1][k])//(只需要比较相邻的两个号码就可以了)
                       break;
                if(k==len)
                {g++;break;}
            }
            if(g!=0)
                break;
        }
        if(g==0)
            printf("YES ");
        else
            printf("NO ");
    }
    return 0;


}


原文地址:https://www.cnblogs.com/jk17211764/p/9677419.html