HDU--杭电--3415--Max Sum of Max-K-sub-sequence--暴力或单调队列

Max Sum of Max-K-sub-sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4913    Accepted Submission(s): 1791


Problem Description
Given a circle sequence A[1],A[2],A[3]......A[n]. Circle sequence means the left neighbour of A[1] is A[n] , and the right neighbour of A[n] is A[1].
Now your job is to calculate the max sum of a Max-K-sub-sequence. Max-K-sub-sequence means a continuous non-empty sub-sequence which length not exceed K.
 


 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases.
Then T lines follow, each line starts with two integers N , K(1<=N<=100000 , 1<=K<=N), then N integers followed(all the integers are between -1000 and 1000).
 


 

Output
For each test case, you should output a line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the minimum start position, if still more than one , output the minimum length of them.
 


 

Sample Input
4 6 3 6 -1 2 -6 5 -5 6 4 6 -1 2 -6 5 -5 6 3 -1 2 -6 5 -5 6 6 6 -1 -1 -1 -1 -1 -1
 


 

Sample Output
7 1 3 7 1 3 7 6 2 -1 1 1

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace
std;
int
a[222222],sum[222222]={0},que[222222];
int
main (void)
{

    int
t,n,m,s,i,j,k,l,max,aa,ss,qian,hou;
    scanf("%d",&t);
    while
(
t--&&scanf("%d%d",&n,&m))
    {

        for
(
i=1;i<=n;i++)
            scanf("%d",&a[i]),a[n+i]=a[i];
        for
(
i=1,sum[0]=0;i<=n+m;i++)
            sum[i]=sum[i-1]+a[i];  //把总和记录下来
        max=-1000000,aa=ss=qian=hou=0;
        for
(
i=1;i<n+m;i++)
        {

            while
(
qian<hou&&sum[i-1]<sum[que[hou-1]])hou--;  //保持单调
            que[hou++]=i-1;
            while
(
qian<hou&&i-que[qian]>m)qian++;  //保持长度
            if
(
sum[i]-sum[que[qian]]>max)
            {

                max=sum[i]-sum[que[qian]];
                aa=que[qian]+1;ss=i;
            }
        }

        if
(
aa>n)aa-=n;
        if
(
ss>n)ss-=n;
        printf("%d %d %d ",max,aa,ss);
    }

    return
0;
}

原文地址:https://www.cnblogs.com/jiangu66/p/3223526.html